On Tuesday November 28th from 9:00AM PT - 12PM PT (5:00PM UTC - 8PM UTC), we will be performing system maintenance on support.mozilla.org. During the maintenance period, users will not be able to sign in to the website, and all users signed in at the start of the maintenance period will be signed out.

This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn't solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter and/r/firefox on Reddit.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop firefox adding "recent" to tasks

  • 4 replies
  • 1 has this problem
  • 7 views
  • Last reply by apmarson

more options

How do I stop firefox adding "recent" to tasks - I've tried changing the "about:config" settings but this doesn't work.

There seems to be no halfway house where you loose All Tasks or have to continue to delete the annoying " recent documents.

Am I missing something?

How do I stop firefox adding "recent" to tasks - I've tried changing the "about:config" settings but this doesn't work. There seems to be no halfway house where you loose All Tasks or have to continue to delete the annoying " recent documents. Am I missing something?

All Replies (4)

more options

Where are you seeing this? Are you talking about a folder in the Bookmarks Manager? If so, that is not a real folder. It is created by the browser. Useful in some cases. Just move that to the bottom of the main bookmarks folder.

more options

I'm seeing it when I right click the Firefox Icon I have pinned to the Taskbar.

It is a folder in the Bookmarks Manager'

more options

You can set what to show there via browser.taskbar.lists prefs on the about:config page.

  • browser.taskbar.lists.recent.enabled

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

This is the route I have been using. It has not worked.

I attach the settings I'm using, maybe someone can guide me to modify.

Note - I wish to keep the "New Private Window" setting