Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Archiving to iCloud does not work, only creates local iCloud folder

  • 6 replies
  • 1 has this problem
  • 21 views
  • Last reply by Andreas

more options

When clicking the "Archive" button; Thunderbird creates a local archive folder instead of moving email to the iCloud archive folder. I have tried various combinations under accout settings -> copies and folders -> message archive to no avail. When I drag and drop a specific message to the iCloud folder it works; but not when I click the archive button.

All Replies (6)

more options

Archive button moves email to the setting as stated in 'Account Settings > Copies & Folders > Message Archives subsection where if 'keep message archives in ' is selected then message is moved to the chosen folder within the account or Local Folders mail account.


If you have created an icloud mail account in Thunderbird and it is set up as an IMAP mail account, then you would need to subscribe to see the 'Archives' folder on the icloud mail account. right-click the icloud mail account name folder in the Folder Pane and select 'Subscribe' click Refresh, and check (subscribe) the desired folders and click on OK

Then you would be able to choose that folder in the 'Copies & Folders' section as mentioned above.

Helpful?

more options

Did resubscribing help - using the Subscribe - Refresh - select folder and click on Subscribe allow you to reselect that subscribed folder in Copies & Folders and then did 'Archive' button move to desired folder?

Is the icloud archive folder also selected in the 'Account Settings' > 'Synchronisation & Storage' section? click on 'Advanced' button to see if folder is selected for download

Helpful?

more options

Hi and thank you for your reply - unfortunately, this is set up correctly but does not solve the problem. The Message Archives and "keep message archives in" points to the correct iCloud Archive folder, it is visible in the left folder pane under "iCloud" and I can drag and drop emails to it which updates the iCloud folder correctly; but if i press the Archive button or hotkey "A" on a specific message thunderbird creates a local folder and moves it there. Has to be a bug, I have tried everything.

Helpful?

more options

Please try the following as a test:

Menu app icon > File > Offline > Download/Sync now Select 'Mail' and 'Work offline once download and/or synchronisation is complete Click on 'Select' and double check all folders have the checkbox selected and click on 'OK' click on 'OK'

Allow everything to sychronise to get up to date and then it will go into offline mode - you will see a change in the bottom left icon in Status Bar.

Then select an email so you see it in Message Pane and click on the 'Archive' button. Report on Results.

You can easily return to online mode by clicking on the far left icon in the bottom Status bar.

Helpful?

more options

What version of Thunderbird are you using and what Operating System ?

Helpful?

more options

Sorry for my late reply, I was trying out Windows mail but I hate it compared to TB. But; Windows mail has no problem archiving my mail in the icloud folder.....

I tried archiving an email while offline as you suggested, but when I clicked "Archive" while working offline nothing happened either by clicking or pressing hotkey "A".

It seems that no matter what iCloud folder I choose under "Message archives" Thunderbird will not put the archived message into an online icloud folder, it always creates a local archive folder and puts it there....:(

Im currently on Win 11 using TB 9.1.1.2

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.