Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox very slow

  • 5 replies
  • 1 has this problem
  • 26 views
  • Last reply by FredMcD

more options

My Firefox browser (92.0.1 64-bit) has been very slow.

And, the "GO back" history does not work well with some Yahoo pages (like, Finance, email...), it keeps fill in the current page each time when I move the page down and up and thus prevents me from being able to go back to the previous pages.

Thank you in advance for any kind assistance on this.

All Replies (5)

more options

As to the 'go back' problem, sometimes when you click on a link, it goes thru not just one but several redirects. This can cause issues as far as going back.

Right-click on the forward/backward arrows. You should see a list of links.


As to the slow issue, can you provide better information? Is this a lot, sometimes? What were you doing at the time? surfing, watching a clip, reading something . . . .


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

Modified by FredMcD

Helpful?

more options

Thank you very much for your response.

I did try troubleshoot mode as you suggested and that seems to have helped resolve the browser slowness issue.

As far as the issue with the go-back arrow goes, at first it looked as though the issue was gone post the troubleshoot mode, only to re-appear after a few minutes. What typically happens is when I go to Yahoo Finance page, for instance, from an existing web page displayed on the browser, and let it sit (when I'm reading the content) for a few minutes, then click the go-back arrow to revisit the previous page, I either have to click the arrow multiple times (if I stayed with that page for less than 2 minutes) to reach the previous page, or if the time I spent on that Yahoo Finance page is longer than 3 minutes, I'd have totally lost the ability to back track to the previous page. The problem is that the browser will start filling the go-back history with the current page location repeatedly, without any actions on my part except reading the content, until the designated buffer gets filled up (14 seems to be the limit). And when the buffer gets filled up with the same current page location, it lost all the previous pages information.

Helpful?

more options

wtshieh said

I did try troubleshoot mode as you suggested and that seems to have helped . . .

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

Thank you again for your response and sorry for my belated reply due to my medical conditions.

It turns out I only have two add-ons, and disabling them did not solve the problem of go-back-one-page arrow buffer being auto filled with repeated same pointer (again, this only occurs on some Yahoo Finance pages). I tried to disable Hardware Acceleration, but was not able to follow the instructions provided on the web link b/c there is no Options for me to choose when I clicked the 3-bar menu. Perhaps the web link content has been outdated by the newer version of Firefox browser.

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.