Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Grant Firefox permissions to microphone and camera in macOS

  • 2 replies
  • 2 have this problem
  • 11 views
  • Last reply by ABC-XYZ

more options

I am suffering from the same issue posted on AskDifferent and since there is no answer there, I thought to paste the question here.

I have installed Firefox (version 90.0.2) on macOS version 11.5.1. In the Camera and Microphone panes under the Privacy tab in Security & Privacy settings, Firefox is missing.

I tried this answer and this, then opened Firefox and navigated to a website that prompted for using the cam and mic.

Yet, when I approved it on Firefox, the Mac privacy dialog did not pop.

How can I give permissions to Firefox for microphone and camera to be able to use them in Firefox? (should it be by modifying the privacy database?) Is this a Firefox bug? Right now, it forces me to use other internet browsers :(

(my System Integrity Protection status is enabled)

All Replies (2)

more options

I'm not sure what settings to which you are referring. In Firefox Settings, Privacy & Security page, you can add websites. On any given site, you can open the page information dialogue (ctrl/cmd+i) and, on the Permissions tab, the last two 'permissions' relate to the camera and microphone. You can also open the dialogue by clicking on the padlock in the urlbar, then the arrow then "More Information".

Helpful?

more options

> I'm not sure what settings to which you are referring.

So you can ask for clarification :) On MacOS, applications must request permissions for accessing resources. Such as microphone and camera.

> In Firefox Settings, Privacy & Security page, you can add websites. On any given site, you can open the page information dialogue (ctrl/cmd+i) and, on the Permissions tab, the last two 'permissions' relate to the camera and microphone.

That won't do a thing, since first a permissions must be granted in the MacOS settings first.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.