Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Download/Sync now feature has stopped working

  • 16 replies
  • 1 has this problem
  • 35 views
  • Last reply by beskeptical

more options

Does anyone have an explanation or solution?

I have an Xfinity/Comcast POP email account through Thunderbird.

For years, I have reliably used the Download/Sync Now button under the Get/Send Messages tab to sync my email back to the server (i.e. delete emails from the server which I've trashed on the Thunderbird client).

Suddenly, out of the blue, and without changing any settings, this feature no longer works, and emails I delete on the Thunderbird client remain on the server.

All Replies (16)

more options

Is this Download/Sync Now button provided by an add-on? A normal POP account has no built in capacity to send delete commands to the server. But syncing with the server is standard with IMAP setups.

Helpful?

more options

No, as far as I can tell, the button is endemic to Thunderbird.

Helpful?

more options

Also, apart from the Download/Sync Now defect which has arisen, Thunderbird apparently no longer even tells the server that my messages are deleted. In other words, deleting them in Thunderbird does not delete them off the server, even though I plainly have my account settings configured to do that.

Helpful?

more options

I just updated to 78.14.0, and it removed the Download/Sync Now button. I am afraid to update further because numerous of my Add-Ons were rendered incompatible by the Update.

Mozilla doesn't deserve its developers given how cavalier it is in wrecking their add-ons. Absolutely pathetic.

Helpful?

more options

Interestingly, one of my two accounts is syncing properly and the other is not.

Helpful?

more options

What was your version before the update to 78, and which add-ons are listed Extensions in the Add-on Manager? Many add-ons were rewritten for 78 and 91.

POP accounts don't sync with the server, but IMAP accounts do sync. Check the Server Type under Server Settings in Account Settings.

Helpful?

more options

Hi. I don't recall. It was whichever version directly preceded 78.

POP accounts do sync if set to, just not bilaterally. That is, they can be set to delete trashed mail off the server. This is how my accounts are set. They always worked until suddenly one stopped working. The other one still does.

It appears that for some reason, Thunderbird is not signaling the Xfinity server when i trash a message. Or Xfiniry isn't processing the signal. Don't know how i would tell

Helpful?

more options

If the POP account is set to delete from the server after download, that is exactly what will happen. But if the setting is 'leave on server until deleted', deleting from TB will not delete from the server. Messages are deleted when they are deleted by some other means, such as from webmail.

Helpful?

more options

Hi. Sorry to say that's just incorrect. Again, my POP3 email messages have been deleting off the server for years, until recently. And they still do properly from one of two accounts

Helpful?

more options

That is to say, my unchanged settings are to leave on server for up to 21 days or until deleted from Thunderbird. And that worked without issue until recently. Go ahead and check out the Thunderbird setting. It's plain as day.

Modified by beskeptical

Helpful?

more options

Download/Sync Now... is under File/Offline, and only applies to IMAP accounts, which are the only type that can sync with the server, and are the only types of accounts that appear in the Select... window (see picture).

Messages in POP accounts are deleted after download if 'leave messages on server' is unchecked, but if that box is checked, they are not deleted from the server just by deleting them in TB.

Helpful?

more options

@sfhowes With all respect, you're just denying reality. You're simply wrong that POP3 settings do not enable delete from server when deleting on client. Not only is that an actual TB account setting, it has worked for years for me, and still works as to one of my two accounts.

(Download/Sync Now is not the issue, not least bc it's not even available in the current version of TB as far as i can tell. It simply used to help force the sync.)

Hoping there's someone who actually knows what they're talking about who can respond.

Helpful?

more options

See TB POP3 Leave messages on server until i delete them setting in screenshot attached

Helpful?

more options

Has anyone else encountered, or does anyone have a solution for this issue?

To re-summarize: I use two Comncast/Xfinity accounts with Thunderbird, both as POP accounts. Email is set to delete off the server when I delete it from Thunderbird. This always worked until recently. Now, suddenly, it still works for one account but not for the other. For that account, email is not deleting off the server. All the settings are the same for both accounts, and I didn't change either one's settings before the one stopped causing mail to delete off Comcast's servers when I delete it from Thunderbird.

Helpful?

more options

You are right about Thunderbird sending a delete command to the server. The POP3 protocol has a delete (DELE) command that clients, such as Thunderbird, can send to the server if configured to do so, just like your screenshot shows you have. I have tested this in a POP-only profile that I keep around for tinkering, using the latest version of Thunderbird and the following was my observation:

  1. When I delete a message from the Inbox of the POP account, it gets moved to the Trash folder as expected, but this is not immediately replicated on the server as is usually the case with IMAP.
  2. After I click Get Messages, Thunderbird checks for new messages and also sends the DELE command to the server. I know this because that message gets trashed on the server.
  3. When I delete another message in Thunderbird then use the Compact Folders feature for the POP account, Thunderbird again sends the DELE command to the server and the message effectively gets trashed on the server.

In Thunderbird, the POP account's server settings are to leave messages on the server until I delete them. There is no Download/Sync button that I can see/find anywhere. This was probably placed there by an add-on or yourself by customizing a toolbar. How you had that button, only you knows. That Download/Sync option is available under the File > Offline menu.

Unfortunately, I have no idea why the DELE command is not working for only one of your two accounts. Try using the Compact Folders option also found under the File menu and see if it triggers server-side deletion.

Perhaps the server-side logs could show if the server is indeed receiving the DELE command from Thunderbird. You'll have to engage Comcast support on this. You could also setup a new Thunderbird profile with just the affected account for testing and see if the problem exists on that fresh profile. This will confirm whether this problem is unique to the old profile or account. In the test profile, configure it to download headers only to speed things up.

Helpful?

more options

@Stans

Thank you. This turns out to be a server side issue with Comcast/Xfinity. Evidently, in the course of troubleshooting my account, they changed a setting (namely to keep POP3 email on server) which prevented deletions when Thunderbird sent the codes.

Creating a second account as you suggested allowed me to isolate the issue.

In short, Thunderbird does allow a user to set delete off server parameters for a POP3 account, and it was working.

Modified by beskeptical

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.