Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to open PDF in library window

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by jscher2000

more options

I have been using Firefox for years, and until today everything was working okay. Now, all of a sudden, whenever I try to open a PDF using my school library's website, I am being asked to either open a PDF in Firefox, Adobe, or save the file. Because my library allows me to view PDF copies of books and access the table of contents, this does not work for me. Again, all was fine yesterday, but today it has suddenly become an issue.



Running Firefox 92.0 (64 bit) on Windows 10.

All Replies (1)

more options

dasmithey67 said

I have been using Firefox for years, and until today everything was working okay. Now, all of a sudden, whenever I try to open a PDF using my school library's website, I am being asked to either open a PDF in Firefox, Adobe, or save the file.

That sounds like the special download dialog for PDFs (the regular download dialog doesn't have "Open in Firefox" as an option).

Is the problem that there is an extra step? Or doesn't the PDF work correctly when you use one of those options?

I can think of two possible reasons for this:

(1) On the Settings page, the instruction for PDFs is "Always Ask"

You can check on that using the steps in this article: View PDF files in Firefox or choose another viewer.

(2) The server is sending Firefox a header that triggers the download dialog

This is the "Content-Disposition: attachment" header, and the only workaround is through an add-on. If you are allowed to install add-ons on this installation of Firefox, I can suggest my own extension. You can install it from the Mozilla Add-ons site:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

To activate it, click its Zzzz button on the toolbar to wake it up. That should take care of #1 automatically. To solve #2, click the button again and in the Content-Disposition Override section of the menu, click "Follow my settings (inline)".

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.