Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

[FF 91.0.2] - Only being able to save the PASSWORD of a specific homepage, but not the USERNAME

  • 7 replies
  • 1 has this problem
  • 35 views
  • Last reply by Thomas

more options

Hello,

saving login data for diffrent homepages works in general. But there is one homepage, where Firefox is just able to save the password, but not the username. For every login, i have to type in my mail adress (username) manually. The site where this happens is: https://www.ebike-connect.com/login?lang=de-de You can try it on your own. Just create an free account and try to save your login data.

P.S.: I tried saving the login data with the edge browser and it was no problem. It can log me in automatically.

Regards Thomas

Chosen solution

Hello FredMcD, hello cor-el,

i found an addon which solves my problem. It is called "Autofill".

https://addons.mozilla.org/de/firefox/addon/autofill-quantum/?utm_source=addons.mozilla.org&utm_medium=referral&utm_content=search

Thank you very much for your help!

Best regards Thomas Steffen

Read this answer in context 👍 0

All Replies (7)

more options

You can try to use "Create New Login" to add this login yourself.

Helpful?

more options

I've already manually added the mail adress as username in the settings, but unfortunately it doesn't help. It seems that Firefox doesn't recognize the textbox for entering the mail adress as a field for putting the username into. I think this behavior has to be fixed by a dev.

Helpful?

more options

OK,m I did some testing and it looks like this is caused by the presence of the autocomplete="new-password" attribute on this input field that Firefox doesn't seem to like. If I remove this attribute then I see "Use Saved Login" in the right-click context menu.

You can use this JavaScript bookmarklet to remove this autocomplete attribute. You can create a new bookmark and paste the JavaScript code in its Location field and invoke this bookmark.

  • javascript:void(document.querySelector('input[type=text][autocomplete=new-password]').removeAttribute('autocomplete'));

I get a consent page when I access the login page for the first time and I can run the bookmarklet on this page to have the input field working once I confirm accepting cookies. I don't know if you can make Firefox auto-fill name and password.

Helpful?

more options

Hey cor-el,

thank you very much. Your script works! I was trying to auto-fill the login data using java script (instead of your script):

javascript:(function(){document.getElementById('login__email').value='maxmustermann@web.de';document.getElementById('login__password').value='MyPassword';this.document.getElementsByClassName("o-button-filled--blue auth__submit-button auth__general-spacing").login_loginButton.click();})();

The problem is, that firefox did not realize, that the textboxes are already filled with the right values. I have to delete and rewrite the last character of the username, and the password. Aftwerwards i have to click the bookmarklet again to login. I have to do further investigations to get this to work automatically. Maybe you have an idea?

Regards Thomas

Helpful?

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

more options

Hello FredMcD,

well, the problem isn't really solved. It's just a workaround and it doesn't works perfect. Other browsers like Microsof Edge for example can save the login data for this homepage. I marked cor-el's answer as helpful, but the devs have to fix this issue with an update in the future, right?

Regards Thomas

Helpful?

more options

Chosen Solution

Hello FredMcD, hello cor-el,

i found an addon which solves my problem. It is called "Autofill".

https://addons.mozilla.org/de/firefox/addon/autofill-quantum/?utm_source=addons.mozilla.org&utm_medium=referral&utm_content=search

Thank you very much for your help!

Best regards Thomas Steffen

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.