On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox slow loading of one website on my Mac - Brand New

  • No replies
  • 1 has this problem
  • 14 views
more options

I'm having a strange problem with one particular website on my Mac that I hope someone here can solve.

I started having this problem on Wednesday morning of this week.

This is the particular website: https://www.underconsideration.com/brandnew/

It loads incredibly slow for me on my iMac. I'm using the Mojave operating system if that helps.

I contacted their website moderator first and foremost to see if anyone else was having this problem but he said there are no other reports. He couldn't offer any help and was also stumped.

Before you offer suggestions, this is what I tried to no avail:

• Restarted Firefox in safe mode with ALL plug-ins and extensions turned off • Refreshed my Firefox browser • Emptied ALL cache, history and cookies • Unplugged and restarted my Mac, modem and router

I really hope someone can help with this strange problem.

I'm having a strange problem with one particular website on my Mac that I hope someone here can solve. I started having this problem on Wednesday morning of this week. This is the particular website: '''https://www.underconsideration.com/brandnew/''' It loads incredibly slow for me on my iMac. I'm using the Mojave operating system if that helps. I contacted their website moderator first and foremost to see if anyone else was having this problem but he said there are no other reports. He couldn't offer any help and was also stumped. Before you offer suggestions, this is what I tried to no avail: • Restarted Firefox in safe mode with ALL plug-ins and extensions turned off • Refreshed my Firefox browser • Emptied ALL cache, history and cookies • Unplugged and restarted my Mac, modem and router I really hope someone can help with this strange problem.