On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDF Settings have no effect

more options

I use Firefox to open a webpage that has PDF forms that I use routinely. Up until yesterday, 8-24-2021, I would click on the link and the form would open in Acrobat as I desire. Yesterday they started opening in the built in PDF preview, which I am sure is nice for some who just want to read a document, but does not meet my needs for signatures, etc.... I am guessing there was an update that was installed. I changed the settings to open PDFs in Acrobat and it continues to open them in the previewer. I change the setting to ask what to do and it continues to open them in the previewer. Is there an additional setting that I am missing someplace?

I use Firefox to open a webpage that has PDF forms that I use routinely. Up until yesterday, 8-24-2021, I would click on the link and the form would open in Acrobat as I desire. Yesterday they started opening in the built in PDF preview, which I am sure is nice for some who just want to read a document, but does not meet my needs for signatures, etc.... I am guessing there was an update that was installed. I changed the settings to open PDFs in Acrobat and it continues to open them in the previewer. I change the setting to ask what to do and it continues to open them in the previewer. Is there an additional setting that I am missing someplace?
Attached screenshots

Chosen solution

You could also try these steps: 1. Navigate to 'about:config'. 2. Double click 'pdfjs.disabled' so that its value is now set to 'true'. 3. Navigate to the file://*.pdf and it should open in System viewer

Read this answer in context 👍 0

All Replies (3)

more options

Try these steps: 1. Right click on a PDF document on your desktop or in Windows Explorer. 2. Choose 'Open With' -> Choose another app. 3. Select 'Adobe Acrobat Reader' and tick the option to 'Always use this app'. 4. Click 'OK' and try opening a link to a PDF in Firefox.

more options

Chosen Solution

You could also try these steps: 1. Navigate to 'about:config'. 2. Double click 'pdfjs.disabled' so that its value is now set to 'true'. 3. Navigate to the file://*.pdf and it should open in System viewer

more options

Thank you JP! I already had Acrobat set as the default but I tried your first suggestions anyway, no change. Your second suggestion did the trick! Thank you!

JP said

You could also try these steps: 1. Navigate to 'about:config'. 2. Double click 'pdfjs.disabled' so that its value is now set to 'true'. 3. Navigate to the file://*.pdf and it should open in System viewer