Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox stopped conwerting HTML to PDF

more options

After my antivirus deleted a malware I get an error message at boot " unable to access jarfile". Since then FF doesn't convert html to pdf and external programs don't start for unable to access virtual machine. The jarfile is binary.SE and the Pass is correct. I have no old java version and I reinstalled the last java version. I understand that binary.SE is no longer supported. The list of extensions also include .jar so I unfortinately don't know what els to check but I do need the FF html converter back. Thank you so much for trying to help. My OS is Windows 7 Pro FF is Developer edition with auto update. Alf

All Replies (2)

more options

You could try removing said startup applications with missing jar file with Win+R -> Type 'msconfig' -> Open 'Startup' -> Uncheck all applications -> Reboot to see if the same error occurs. Optionally, you could try reinstalling your JRE and Firefox to see if the problem persists. Make sure that when in Firefox you press Ctrl+P that you are seeing the Microsoft Print to PDF or Adobe PDF in the Print dialog.

more options

Hello, thank you for your help. At FF ctrl+P are only HP and MS printer, no PDF, also I can not safe as PDF. I have uncountable old Java files including in the roaming folder. Th error message Java virtual machine launcher: unable to access Jarfile point to a wrong address C:\User\Owner\dNWFiFJDLfW\ jYHGewDFiUY.ccstMN does not exist. The folder is \ujhtYUUIFDC\ 3 long name files .Yxwht EXT. dated back to 2019. Windows can't find old address nor ccstMN, nor the error message, virtual machine launcher or virtual machine. I ran Belarc Advisor which also didn't see a virtual machine. In the Win ctrl panel were 2 java updates 1.8.301, I uninstalled them one by one restarting each time, but the error is stil there. Now I reinstalled Java but the error is still there. There are more then 100 old files left over after uninstalling from 2012 to 2020, asuming that many still be used and some applets, api my have been deleted during the update. So where does the error come from? where is the JAMS and how to use it? also the default FF Browser option in the javacpl does not work but work for MS EIE. How can I get rid of all the old files everywhere for a clean installation? The issue is still there. The browser does not convert HTML or print PDF. The error message is still there and I couldn't find a program that does conversions without a functioning Java. Sorry for the long story. I wish you a nice day, Alf