Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Allowing Insecure Content

  • 4 replies
  • 1 has this problem
  • 43 views
  • Last reply by cor-el

more options

Using a Windows 10 device. I currently have an HTTPS:// web address that I am connecting to using the most current version of Firefox. I am attempting to transfer data from HTTPS:// to a an HTTP:// web address. It seems like the Browser is not allowing the transfer. I have attempted the same process in different web browsers with a similar problem; but after allowing insecure content for the site in other web browsers, the transfer is successful. How do I configure the most current version of Firefox to allow insecure content for a specific HTTPS:// website.

All Replies (4)

more options

Is this about embedding mixed content on a secure HTTPS webpage ?

Firefox normally allows mixed display content (images coming over http://), but blocks mixed active content (iframes and scripts).

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection.

See also:

Helpful?

more options

Thank you for your response. I'm actually working with digital Forms that are being sent from HTTPS:// content server to HTTP:// cache server for access later while off line. The sites are displaying fine, it is the digital content that seems to be getting blocked during the transfer from being received by the cache server.

Helpful?

more options

Hello, are you trying to POST a form to a HTTP URL while the webpage is loaded on HTTPS? This looks like an active content as per the mixed content page. Do you see any errors on the web console for the form submit ?

Thank You

Helpful?

more options

Note that Firefox shows a warning if you send a form from HTTPS to HTTP, but it is not advised to disable this warning as it is there for a reason

  • about:config => security.warn_submit_secure_to_insecure

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.