Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

McAfee WebAdvisor stopped working, icon stays grey after updating to 91

  • 2 replies
  • 1 has this problem
  • 8 views
  • Last reply by Max7777

more options

I have tried several ways to fix it, but it appears something about the update to the latest Firefox is not allowing it to warn me about bad websites. Does any one know why this may be?

All Replies (2)

more options

Have you contacted McAfee support?

Helpful?

more options

No I have not McAfee support... and I also did not contact Santa Claus, because neither of them broke McAfee Webadvisor... loading up Firefox 92 broke it, and that is why I was asking here. But thanks so much for chiming in.

I solved it by rolling back my computer to Firefox 91... and now McAfee works fine again.

This is not the first time loading the new version broke McAfee, it seems some people here do not like it....

oh well.... it may be time to find a new better browser than Firefox, like so many other people have.

Look up the headlines....

Firefox Has Lost 46 Millions Users in Three Years ...

Firefox May Have Lost Up To 12% Of Its Users So Far In 2021....

And they all probably switched because of too many breaking things with new Firefox loads, WHICH HAPPEN TOO OFTEN! and when I update it and it breaks..... there is no helpful replies here except for "DID YOU CONTACT SOMEONE ELSE" aka "WE DONT CARE!"

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.