Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Authentications problems on Amazon with Firefox 90.0.2 for Linux

  • 2 replies
  • 1 has this problem
  • 9 views
  • Last reply by john.mohr

more options

Greetings I use Firefox on Fedora 34 Linux. This is a good quality desktop system, less than a year old. This is my daily driver but I also have a laptop running windows 10 and Firefox.

A couple weeks ago I did a normal system update which included Firefox version 90.0.2. Since that update I have been unable to access my account on Amazon. I can bring up the Amazon web page and I can login as myself. The problem is that I can't put anything in my cart. I get an error page that says "Sorry something went wrong on our end." In the browser console I see an error, "HTTP/2 503 Service Unavailable". I can sometimes view my cart, but most often I can't. Also, when I click on my account information, I get another error page that says, "Sorry we couldn't find that page." The browser console shows a number of "503 Service Unavailable errors", but the last line shows this error (in it's entirety). "GET https://www.amazon.com/gp/css/homepage.html?ref_=nav_AccountFlyout_ya [HTTP/2 404 Forbidden 215ms]. So, basically I can browse products, but I can't order anything or change any of my account information using Firefox.

So, even though I am logged in, I am being denied access to my account information, including ordering.

These are the things I tried to mitigate the probem.

Cleared browser cache Cleared all cookies and data for Amazon Tried different security settings Reverted to all default settings for browser Removed Firefox with the dnf utility and deleted all residual Firefox directories that I could find, including in my home directory Reinstalled Firefox 90.0.2 from Fedora 34 repository

The same problem persists. I get exactly the same behavior. There is no problem using Chrome on the same Linux machine. This is my workaround. There is no problem using Firefox 90.0.2 on my Windows 10 laptop. I only see the problem in Firefox on my Linux desktop which is less than a year old and gives me no other problems what-so-ever.

So far I have not found this or a similar problem on any other website, only Amazon.

I added a screenshot of the last entries in my browser console log which may or may not help.

Thanks for listening.

Attached screenshots

All Replies (2)

more options

I'm not able to replicate the issue. see screenshot Anything blocked? Can you try running a separate copy of Firefox to see what happens. Just download to a folder and run it from there. I run 2 versions of 90.0.2, one from my distro and another from a folder. Try it before and after you log into you Firefox account. Are you using Lockwise to fill in your password? I noticed in the pass that Firefox would sometime try a generated password instead of my password.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Operating System: openSUSE Tumbleweed 20210806 KDE Plasma Version: 5.22.4 KDE Frameworks Version: 5.84.0 Qt Version: 5.15.2 Kernel Version: 5.13.6-1-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Modified by jonzn4SUSE

Helpful?

more options

Thanks for your quick reply.

I downloaded the bzipped file from your link and extracted it to a clean directory. That WORKED! Then, to ensure myself that my system didn't magically fix itself, I tried again using the version from the Fedora repo. That version is still broken. I tried each version several times with the same results.

So, to recap: The newly downloaded bzipped file produced a working Firefox application with no errors and did what was expected. The resident Firefox application installed from the Fedora repository is still not working correctly.

I seem to remember running into a similar situation long ago where a repo app didn't work, but a version downloaded from a website did work. I think it wasn't Firefox, but some other application. So, it happens.,

I could kludge together a fix from this info, but it would be nice if the repository version worked.

Thanks, John

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.