Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Data clogging my browser.

  • 3 replies
  • 1 has this problem
  • 4 views
  • Last reply by cor-el

more options

My Firefox browser is constantly showing 1 GB of disk space used. I've set up automatic clear of site data and cookies. I'm constantly having to clear all data and then sign in to all my usual websites all over again. I'm not able to get onto my banking websites most likely due to this data clog. I'm SO TOTALLY tired of this constant cycle of trying to clear my data and accessing my usual websites. I'm using Firefox for many years without this trouble. I'm one week away from changing browsers. If I go to Safari I am not finding this trouble. Chrome is my next choice. I use my Mac computer for personal use only and my firefox is up to date. I'm using Big Sur on my macbook pro. What is going on?? Without a solution I'm out of here.

All Replies (3)

more options

You can find out which tabs and addons are using resources with Task Manager (Menu Bar > Tools > Browser Tools > Task Manager or 3 bar menu > More Tools > Task Manager). This article may help: https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-or-cpu-resources

Helpful?

more options

Hi, it's more likely the disk cache that would be using gobs of space, and not the cookies and site data.

Try keeping the cookies and site data, but clearing the "Cached Web Content" and see whether that helps. That's one of the two checkboxes when you click the Clear Data button on the Settings/Preferences page.

If you have a high bandwidth connection, you can turn off the disk cache to save on disk space. Here's how if you want to try it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.cache.disk.enable and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Helpful?

more options

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.