Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No Netflix or Amazon Prime on Firefox 90.0.2. (64bit) for MacOS Catalina - Widevine issues

  • 8 replies
  • 1 has this problem
  • 91 views
  • Last reply by cor-el

more options

Netflix and Prime Video do not allow video playing and give me errors associated with Widevine. Thing is, all the threads I have found about Widevine issues for Firefox on MacOS say that new widevine is not supported on or before MacOS 10.11.

I am using a MacbookPro 13" 2012 Running MacOS 10.15.17 (Catalina) Firefox 90.0.2 (64-bit)

Installed Firefox 78.9.0esr as suggested roll back solution and it did not change anything. Reinstalled Firefox 90.0.2 and now Firefox Plugins section is is telling me that "Widevine Content Decryption Module provided by Google Inc. will be installed shortly." but it doesn't seem to change. I have always stayed updated on MacOS and Firefox versions, and suddenly in early 2021 this has become an issue that persists to date.

Is the current status of Widevine for Firefox on MacOS BROKEN?

There are no roll backs that seem to work, and I can't find anyone else with my MacOS and Firefox versions that are reporting the same problem. Streaming is not only the way of the future, it has been the standard for media viewing for over 5 YEARS. Firefox needs to figure how to make widevine work from the get go or it will quickly go the way of the dinosaur.

I don't WANT to use Chrome (thought I currently do for Netflix), please don't suggest that as a solution.

Chosen solution

As you can see by the lat few lines, Firefox isn't able to download the ZIP archive that contains the Widevine plugin.

It is possible that your security software blocks this request or you may have an hosts file, so you need to look into this.

Read this answer in context 👍 0

All Replies (8)

more options

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?


Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Here are the errors as reported: a) In troubleshooting mode playing Netflix video demonstrates as if loading, but hangs, and Firefox displays in a little message bar at the top: “Firefox is installing components needed to play the audio or video on this page. Please try again later.” b) Eventually, Netflix video goes to a page: “Pardon the interruption: We’re having trouble playing Netflix. Please make sure you’re using the latest version of Firefox and try again.”

Problem b) is my original issues, same as when trying to play a Netflix video in regular Firefox mode.

Problem a) happens after I delete and clean install the new Firefox version in attempt to fix the issue. I know I have had this problem beforem but that it was somehow fixed so that I only had issue b). Currently I have both issues again, and nothing has changed in two days.

I have Sophos Free security installed on MacOS, but have all shields disabled with no change.

Modified by pMa1

Helpful?

more options

Note that you need Widevine 4.10.2209.1 to play DRM protected media (about:plugins), older Widevine versions are no longer supported.

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

Helpful?

more options

I previously had Widevine 4.10.2209.1 and was having problem B), now in Plugins sections I cannot get a version number and I get the yellow banner underneath Widevine that says "Widevine Content Decryption Module provided by Google Inc. will be installed shortly."

Toggling 'Play DRM' in Settings does not change anything.

Helpful?

more options

You should see an initial GMP XHR request and one or more redirects in the Browser Console if you toggle the DRM setting in Settings (Options/Preferences) off/on. Make sure you aren't blocking this request on the OS level.

Helpful?

more options

After unchecking Play DRM-controlled content, and immediately after re-checking it, Console reports:

22:26:39.510 XHRGEThttps://aus5.mozilla.org/update/3/GMP/90.0.2/20210721174149/Darwin_x86_64-gcc3/en-US/release/Darwin 19.6.0/default/default/update.xml [HTTP/2 200 OK 92ms] 22:26:39.646 XHRGEThttps://redirector.gvt1.com/edgedl/widevine-cdm/4.10.2209.1-mac-x64.zip 22:26:39.648 1627269999648 addons.productaddons WARN Failed downloading via XHR, status: 0, reason: error 22:26:39.648 1627269999648 Toolkit.GMP ERROR GMPInstallManager.simpleCheckAndInstall Could not check for addons: {"status":"failed","results":[{"id":"gmp-widevinecdm","result":"failed"}]} Log.jsm:723 22:27:20.631 GEThttps://support.mozilla.org/en-US/questions/1344727?utm_campaign=questions-reply&utm_source=notification&utm_medium=email#answer-1429546 [HTTP/1.1 200 OK 586ms]

Modified by pMa1

Helpful?

more options

Comment removed due to double post.

Modified by pMa1

Helpful?

more options

Chosen Solution

As you can see by the lat few lines, Firefox isn't able to download the ZIP archive that contains the Widevine plugin.

It is possible that your security software blocks this request or you may have an hosts file, so you need to look into this.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.