Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox on linux seems to default to mobile - how to change globally

  • 4 replies
  • 1 has this problem
  • 28 views
  • Last reply by KT

more options

Hello, I have Firefox on all of my devices (Win10Pro, Fire tablet, Samsung phone, etc.). Recently got a Raspberry Pi 4 (Linux) with a 24" (1920x1080) monitor and Firefox (78.11.0esr 32 bit) seems to 'default' to Mobile. How do I change to Desktop globally? Google Search comes up in the middle third of the screen. (Search dropped "Linux" from the search I tried on subject - Google is becoming worthless.) Amazon.com comes up as text on the left side. I don't want to have to manually change from Mobile to Desktop for each site that I visit. PLEASE, don't make me use Chromium....

Thanks!

Chosen solution

Maybe the sites are reacting to armv71. Do you want to try modifying that? For example:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste general.useragent.override and pause while the list is filtered

Firefox usually will display a bar with choices of 3 preference types and a + button. If instead you see an existing preference value, skip the next step.

(3) Select String and click the + button to create a new preference

(4) If necessary, double-click the preference to display an editing field. In the field, type or paste the following, then press Enter/Return or click the blue check mark button to save the change.

Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko.20100101 Firefox/78.0

I don't know whether that might cause sites to try different code that isn't compatible with your processor. ???

Read this answer in context 👍 1

All Replies (4)

more options

What is the user agent string of Firefox running your Raspberry Pi? You can find that on a fingerprinting test site or probably lots of other ways. I have a test page here if needed (it's the test in red): https://jeffersonscher.com/res/jstest.php

Helpful?

more options

Hi Jefferson,

Your site shows: Browser "User Agent" string: Mozilla/5.0 (X11; Linux armv71; rv:78.0) Gecko.20100101 Firefox/78.0

Sorry, can't get my Win10 talking to my RPi... have to type between screen and can't copy/paste.

Kurt

Helpful?

more options

Chosen Solution

Maybe the sites are reacting to armv71. Do you want to try modifying that? For example:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste general.useragent.override and pause while the list is filtered

Firefox usually will display a bar with choices of 3 preference types and a + button. If instead you see an existing preference value, skip the next step.

(3) Select String and click the + button to create a new preference

(4) If necessary, double-click the preference to display an editing field. In the field, type or paste the following, then press Enter/Return or click the blue check mark button to save the change.

Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko.20100101 Firefox/78.0

I don't know whether that might cause sites to try different code that isn't compatible with your processor. ???

Helpful?

more options

Thank you. That seems to have done it.... no problems with Amazon or Google Search. Now I just have to find a search engine that doesn't parse my query to something that the opposite of what I'm looking for...

Thanks, Kurt

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.