Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add on not loading

  • 6 replies
  • 1 has this problem
  • 42 views
  • Last reply by gtevi

more options

I am trying to package an add-on that I created with a custom installer for firefox nightly, but the add-on is not being automatically installed with the browser.

I followed the instructions at https://support.mozilla.org/en-US/kb/repackaging-windows-installer and at https://support.mozilla.org/en-US/kb/deploying-firefox-with-extensions, but to no avail.

Any help would be greatly appreciated.

Modified by gtevi

All Replies (6)

more options

Did you sign the add-on on AMO?

Helpful?

more options

No, but using firefox nightly, I changed the setting xpinstall.signatures.required to false using a preferences file in browser/defaults/preferences and thought that should work. Is that not possible?

Modified by gtevi

Helpful?

more options

> No, but using firefox nightly, I changed the setting xpinstall.signatures.required to false using a preferences file in browser/defaults/preferences and thought that should work. Is that not possible?

Did you make that change in the nightly you were packaging as well?

I can't make any guarantees that will work with nightly.

I would recommend signing the addon on AMO as an unlisted addon.

Helpful?

more options

Yes, I made that change, and when I reloaded it on a new profile, it worked.

But I will sign the addon as unlisted, as you suggested

Helpful?

more options

If you need an "official" version of Firefox that definitely supports unsigned addons, you can use the ESR.

Helpful?

more options

Thank you, that was very helpful

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.