Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening PDFs

  • 2 replies
  • 1 has this problem
  • 8 views
  • Last reply by Stanwoodjh

more options

Hello. Does anyone know how to set up Firefox to open PDFs automatically without this little screen popping up? To me, automatically means to just opens with Adobe, but I still keep getting this screen - which I don’t want. The fewer the steps/clicks I have to do the better. Thanks in advance. Using a Windows 10 Home Edition Desktop Firefox Version 9.0

Attached screenshots

Chosen solution

Yes, but...

Firefox will follow your instructions on the Settings page for Portable Document Format (PDF) -- more info on how to set that in View PDF files in Firefox or choose another viewer -- if two conditions are met:

(1) The server sends Firefox this header:

Content-Type: application/pdf

If the server sends a different content-type, Firefox usually won't match it up with the saved instructions for application/pdf.

(2) The server does NOT send Firefox this header:

Content-Disposition: attachment

This triggers the download dialog Every. Single. Time.


I have an add-on to work around these two problems. You can install it from the Mozilla Add-ons site:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

To activate it, click its Zzzz button on the toolbar to wake it up. That should take care of #1 automatically. To solve #2, click the button again and in the Content-Disposition Override section of the menu, click "Follow my settings (inline)".

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Yes, but...

Firefox will follow your instructions on the Settings page for Portable Document Format (PDF) -- more info on how to set that in View PDF files in Firefox or choose another viewer -- if two conditions are met:

(1) The server sends Firefox this header:

Content-Type: application/pdf

If the server sends a different content-type, Firefox usually won't match it up with the saved instructions for application/pdf.

(2) The server does NOT send Firefox this header:

Content-Disposition: attachment

This triggers the download dialog Every. Single. Time.


I have an add-on to work around these two problems. You can install it from the Mozilla Add-ons site:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

To activate it, click its Zzzz button on the toolbar to wake it up. That should take care of #1 automatically. To solve #2, click the button again and in the Content-Disposition Override section of the menu, click "Follow my settings (inline)".

Helpful?

more options

Jeez - that is genius. It seems strange to me that this is not part of the normal functionality of the browser, but THANK YOU for figuring this workaround out and providing it!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.