On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

MSN launches when I first open Firefox-It's not the homepage setting

  • 1 reply
  • 1 has this problem
  • 25 views
  • Last reply by FredMcD

more options

This just started today (7/5/21). When I first log into my PC and open Firefox, an MSN window opens up instead of my homepage.

My homepage setting has not changed. It's still www.duckduckgo.com. If I close the Firefox and re-open it, my homepage appears. As soon as I log in the next time; however, the first thing that opens is the MSN window again, and the cycle continues.

I'm running Windows 10, which is up-to-date. Firefox is up-to-date too. I haven't done anything. I haven't changed any settings or installed anything. This happens with my wife's user account starting today as well.

The closest archived topic I could find was the one below. None of the recommendations work. How do I stop this from happening?

https://support.mozilla.org/en-US/questions/1267862

This just started today (7/5/21). When I first log into my PC and open Firefox, an MSN window opens up instead of my homepage. My homepage setting has not changed. It's still www.duckduckgo.com. If I close the Firefox and re-open it, my homepage appears. As soon as I log in the next time; however, the first thing that opens is the MSN window again, and the cycle continues. I'm running Windows 10, which is up-to-date. Firefox is up-to-date too. I haven't done anything. I haven't changed any settings or installed anything. This happens with my wife's user account starting today as well. The closest archived topic I could find was the one below. None of the recommendations work. How do I stop this from happening? https://support.mozilla.org/en-US/questions/1267862

All Replies (1)

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.