Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows 11 and Mozilla VPN

  • 11 replies
  • 4 have this problem
  • 186 views
  • Last reply by fbuccino

more options

Hello all.

My system updated to Windows 11. Initially, everything was fine. Now, the VPN will fail saying there is a background service error. I've tried manually starting the service and I get a path not found error. Has anyone else seen this? Have a fix? I'm assuming Microsoft either broke something, or is actively preventing this from operating.

Hoping it will get ironed out before the full release of Windows 11 but thought I'd ask here in case anyone had more info on the issue.

Thank you

All Replies (11)

more options

For the moment, I've rolled Windows back to 10. However, if someone knows how to fix the VPN, please advise. I'd like to keep testing 11 if I can.

Thank you!

more options

Tried Windows 11 again. Upon initial upgrade, VPN works. Rebooted the system, VPN no longer works. It tries but returns a background service error. the Mozilla VPN (tunnel) service will not start. Here is the log:

link text

more options

Hi there,

thank you for posting on the forum!

We have not developed a client for Windows11 yet, we are still testing this on our side. At the moment Mozilla VPN is only compatible with Windows 10 on a 64-bit system.

It is expected to be fixed on the next update.

more options

When is the next update? I expect a full refund for the service I paid for and am not receiving. I like to get what I pay for as is my right.

more options

It seems to be working for me now! I had to re-download and run the installer again to update it, but now it seems to be running.

more options

Oh really? Did you reboot and try it a second time? I found that it would usually work once. Then, after a reboot it would fail. I'll definitely try it if you have success.

more options

Hi there,

to jump into this conversation: the update and launch to VPN version 2.4 should have fixed the compatibility issue and is now available for Windows 11.

I can also suggest a full reset of the app on your Windows if you having any problems:

1.) Before doing the following, double-check the task manager (you can search for this or press control+alt+delete to bring it up) to ensure that the VPN is not currently open. If it is open, right-click the process in the task manager and select "End task"

2.) Uninstall Mozilla VPN from your device.

3.) Now, open the Windows "File Explorer". Click on the "View" tab at the top of the window. On the far right side of the option near the top of this tab, you should see a box called "Hidden Items". Ensure you have checked the box so you can view hidden files and folders.

4.) Now that you can view hidden items, click on "This PC" on the left side of the File Explorer. Now click on your hard drive (This should be labeled "Windows (C:)" and will be towards the bottom of the window. From here, open the Users folder and open the folder for your user. Now find and open the AppData folder, open "Local", and open "Mozilla".

5.) Inside the Mozilla folder, you should now see a folder for Firefox (if you have the Firefox Browser installed) and another for FirefoxPrivateNetworkVPN or Mozilla VPN. Right-click on the FirefoxPrivateNetworkVPN folder and choose the delete option. Ensure that you do not delete the "Firefox" folder. Restart your system.

6.) Now, re-install the VPN from vpn.mozilla.org and attempt to open it and connect.

more options

Good Morning,

Thank you for the reply. Just an FYI, I worked on it last night. However, I simply ran the newer file expecting it to update the product. However, it ran into issues removing the service and gave a permissions error. At that point, the whole script broke and was asking for the proper executable to run the uninstall. I ended up manually removing all references to the VPN by running RegEdit and physically deleting the Mozilla and VPN folders. In the end, I was successful but I would mention to others, definitely run the uninstall first!!

Thanks for the info and so far, it is working well.

more options

Hello,

thank you for the feedback and sharing your experience! We appreciate the time taken to post this on the help forum, it will assist other users who have the same problem. We have taken note of this reply as well and will make sure to mention this step in the future.

Thank again and I hope you keep enjoying the product!

more options

I am running the latest Mozilla VPN (2.4.1 currently) and it seems to be broken again with Windows 11 build 22454.1000. I did not have Mozilla VPN previously installed and today was the first time. I left Nord VPN for their refusal to support Windows 11 (yet). I would love to stay with Mozilla VPN.

more options

11/10/21 I'm still having the same problems with Windows 11 and Mozilla VPN. I've tried all the uninstall and reload thing a few times. Everything works fine when the VPN isn't installed.