Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google News often stops loading

  • 9 replies
  • 2 have this problem
  • 34 views
  • Last reply by mwrr

more options

When I go to Google News in my Firefox browser, it often (usually) only loads part way, then I see a small spinning circle that just stays there. I've now switched to the Edge browser for Google News and it works fine.

All Replies (9)

more options

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

I tried troubleshoot mode and it didn't help at all.

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia


If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

Helpful?

more options

I'm too busy to put time into trying that, especially since Google News works fine for me using Edge.

Helpful?

more options

I did disable my eSet antivirus, and that made no difference. But for whatever reason, in Firefox that "spinning circle" now lasts 20-25 seconds instead of forever. In Edge it does appear but lasts 2-3 seconds.

Modified by mwrr

Helpful?

more options

I have this problem too, under both Linux and Windows. It just hangs for a few seconds, sometimes Firefox even has a message that the website crashed which disappears when it's loading again. Behavior started a few weeks back.

mwrr said

I did disable my eSet antivirus, and that made no difference. But for whatever reason, in Firefox that "spinning circle" now lasts 20-25 seconds instead of forever. In Edge it does appear but lasts 2-3 seconds.

If even Edge has it, it sounds rather like a Google-problem than a Firefox-problem.

I thought so, and tried to send them a ticket about it, but that's rather hard to do. Anybody know how?

Modified by leonavis

Helpful?

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

more options

In my case Google-News loads normal again.

Helpful?

more options

Google News loaded just fine for me on Firefox this morning. We'll see...

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.