Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using Firefox Browser

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by FredMcD

more options

I have downloaded and installed Firefox as a browser on a IMax. Whenever I try to search, Google comes up in the search window.

All Replies (2)

more options

Hi, it means that Google is your default search engine. It's a normal situation.

Helpful?

more options

Type about:preferences#search<enter> in the address bar. You can select any search engine to be your default from here.

You can also remove any engine from here.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.