Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox (89) will not let me connect to the router - keeps switching to https

  • 3 replies
  • 1 has this problem
  • 2 views
  • Last reply by jscher2000

more options

How do I stop Firefox requiring https when my router is only http?

All Replies (3)

more options

Could you make sure this feature is not turned on, or make an exception for your router:

HTTPS-Only Mode in Firefox

Helpful?

more options

Thank you for this. I turned this feature off and Firefox still converted my call to http://192.168.1.1 to https://192.168.1.1 and reported being unable to connect to the https address. So Firefox did not allow me the opportunity to set an exception as it never seemed to actually call the http address. Is it Firefox that is switching the address?

Helpful?

more options

There are two built-in features that could change http to https:

(1) HTTPS Only mode -- you have disabled this

(2) HTTP Strict Transport Security (HSTS) -- normally this would not apply to local IP addresses, unless that server itself previously told Firefox to always use HTTPS, over an HTTPS connection, so I don't think this is the issue

There also are some add-ons that might try to upgrade a connection, such as HTTPS Everywhere, but I don't know whether it would do that for a local IP address.

Any difference if you add the standard HTTP port number to your full URL?

http://192.168.1.1:80/

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.