Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't fix my fonts

  • 2 replies
  • 1 has this problem
  • 10 views
  • Last reply by sdhillon

more options

For some unknown reason, my default fonts are not appearing correctly in Firefox. Here are the things I've tried:

1. I've checked the same sites with Edge and Chrome. 2. I checked the "Fonts and Colors" section of Firefox - both the regular and Advanced parts. 3. I've done the Firefox reset (I can't remember what it's actually called). 4. I've uninstalled/reinstalled. 5. I've deleted the Mozilla folder from my %AppData% folder. 6. I've signed out and uninstalled/reinstalled. 7. I've disabled all extensions and plugins. 8. I've made sure I have the newest version.

The only time it works correctly is when I run Firefox in Troubleshooting mode.

Attached screenshots

Chosen solution

sdhillon said

The only time it works correctly is when I run Firefox in Troubleshooting mode.

Some of the headline differences between regular and troubleshooting modes are:

  • Disables all extensions
  • Disables userChrome.css and userContent.css files
  • Disables hardware acceleration of graphics -- this also affects font smoothing. To test disabling hardware acceleration, see Firefox's performance settings.
  • Disables some or all JavaScript compilers
  • Disables the shared font list (helps with crashes on Arch Linux and some other platforms)

Regarding that last point, you can test whether that is relevant with this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.e10s.font-list.shared and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

I suspect that won't take effect until the next time you quit and restart Firefox.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

sdhillon said

The only time it works correctly is when I run Firefox in Troubleshooting mode.

Some of the headline differences between regular and troubleshooting modes are:

  • Disables all extensions
  • Disables userChrome.css and userContent.css files
  • Disables hardware acceleration of graphics -- this also affects font smoothing. To test disabling hardware acceleration, see Firefox's performance settings.
  • Disables some or all JavaScript compilers
  • Disables the shared font list (helps with crashes on Arch Linux and some other platforms)

Regarding that last point, you can test whether that is relevant with this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.e10s.font-list.shared and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

I suspect that won't take effect until the next time you quit and restart Firefox.

Helpful?

more options

I disabled the shared font list and it did the trick! Thanks so much for your help!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.