Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't characterize websites because of the favicon overlaid by the speaker symbol.

  • 4 replies
  • 1 has this problem
  • 7 views
  • Last reply by Mike

more options

Hi guys.

I can't characterize websites because of the favicon overlaid by the speaker symbol (directly in the YouTube tab).

Is there a way to display the speaker symbol and the favicon at the same time? Or not display the speaker symbol at all, because it is important for me to know which website is in the TAB. I don't need to see the speaker, but the favicon of the website. See attached screenshot.

Of course, the speaker icon only appears when audio is active on a particular website (for example, this applies to a YouTube website).

Thanks.

Mike


Firefox 89.0 (64-bit) Windows 10 (64-bit)

Attached screenshots

Modified by Mike

Chosen solution

This can be done if you're comfortable with using a userChrome.css file. (If you haven't done so before, here's an introduction to how to do so: https://www.userchrome.org/how-create-userchrome-css.html)

The code to bring back the favicon is:

  .tab-content .tab-icon-image {
    opacity: 1.0 !important;
  }

If you want to hide the speaker icon (it probably looks kind of messy when overlaid on the favicon) then:

  tab[soundplaying] .tab-icon-overlay {
    display: none !important;
  }

Related: https://support.mozilla.org/en-US/questions/1339041 (this is how I stopped the 'mute' icon from interfering with the favicon).

Read this answer in context 👍 1

All Replies (4)

more options
    • this post was deleted by the interviewer

Modified by Mike

Helpful?

more options

Chosen Solution

This can be done if you're comfortable with using a userChrome.css file. (If you haven't done so before, here's an introduction to how to do so: https://www.userchrome.org/how-create-userchrome-css.html)

The code to bring back the favicon is:

  .tab-content .tab-icon-image {
    opacity: 1.0 !important;
  }

If you want to hide the speaker icon (it probably looks kind of messy when overlaid on the favicon) then:

  tab[soundplaying] .tab-icon-overlay {
    display: none !important;
  }

Related: https://support.mozilla.org/en-US/questions/1339041 (this is how I stopped the 'mute' icon from interfering with the favicon).

Helpful?

more options

This is affected by the Density settings you can select on the Customize page. In Compact mode you only see the sound playing icon and not the website favicon. In Normal mode you see the favicon by default and the sound playing icon on hover, there is a secondary line that shows the 'playing' or 'muted' state since the icon is hidden by default.

Helpful?

more options

Well thank you @cor-el. It's true. After switching from Compact mode to Normal (adjusting the settings for the toolbars), the speaker symbol will change from favicon when you drag the mouse over the Youtube TAB. However, I would like to use Compact mode and at the same time see the favicon + speaker icon (or a similiar favicon for "playling" status) as before. This is because Normal mode shows larger TABs than Compact mode.

So... for my purpose, the first CSS code from @pg_78 helped. Thanks ! In this case, I see a favicon according to Youtube when playing a Youtube video - it's a symbol of a red speaker playing - it's probably the original favicon (sent from the Youtube website). So, I know that there is Youtube website on this TAB and at the same time that some video is being played there.

Thanks guys... thank you both for the quick reply.

Modified by Mike

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.