Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

graphics problem? images are corrupted, text is blocky / discolored / missing

more options

seemingly at random, images displayed in firefox will look incredibly messed up (like artifacting, and discolored chunks or stripes), text will be missing (as small as a few letters or as much as a page having no visible text at all), text will be discolored (usually a bright color like neon green or pink), and/or or text will appear blocky (sometimes manifesting as the font looking a little thicker and less HD, sometimes as bad as just being illegible rectangles). text with missing letters is able to be read while highlighted, but text that has become blocky is still unable to be read (still blocky) even while highlighted. i don't know if discolored text is affected by highlighting.

these issues happen regardless of what website i'm on, and will also happen on new tab pages or on firefox settings pages. it isn't consistent, it comes and goes. refreshing the page doesn't help or change anything, but if i close the tab and then navigate to the page again it's often different.

i've attached all the examples i've thought to capture, which isn't much. it can make the browser practically unusable at times.

i have firefox version 89.0 (64bit, auto updates enabled), on a windows 10 with 8GB of RAM and AMD FX-9800P RADEON R7 (i honestly.. don't know what that part means, but thought it could help) i previously had "Use recommended performance settings" and "Use hardware acceleration when available" enabled in firefox, but i turned them both off in an attempt to fix the problem. it didn't help.

i can't say for sure when this issue began, as i haven't used firefox much until recently, but i think it's been happening for over a month now. none of the other programs i use appear to be having visual problems, just firefox. at some point a year or more ago, i ran firefox on this computer without issue.

Attached screenshots

Chosen solution

Such issues are usually caused by a problem with hardware acceleration in Firefox, but you wrote that disabling this feature didn't work. You did close and restart Firefox as this is mandatory ?

You can also try to disable WebRender via the about:config page.

Read this answer in context 👍 0

All Replies (6)

more options

Seems like we share a similar problem.

https://support.mozilla.org/en-US/questions/1338943

This appears to be to be across multiple platforms.

Yours: AMD Windows Mine: Raspberry Pi Linux

Have you got "OpenH264 Video Codec" plugin enabled ? With a "will be installed shortly" message ?

Helpful?

more options

pleiades-1997 said

Seems like we share a similar problem. https://support.mozilla.org/en-US/questions/1338943 This appears to be to be across multiple platforms. Yours: AMD Windows Mine: Raspberry Pi Linux Have you got "OpenH264 Video Codec" plugin enabled ? With a "will be installed shortly" message ?

it looks like i do have that enabled, but it doesn't have the "will be installed shortly" message.

Helpful?

more options

radicalstripes said

it looks like i do have that enabled, but it doesn't have the "will be installed shortly" message.

Did you have the open H.264 DLLs installed prior to upgrading Firefox (built from www.openh264.org)? Or download and installed from another source ?

Secondly do you also have the issue on the checkboxes in the Firefox's "Settings" page ? (see second screendump from https://support.mozilla.org/en-US/questions/1338943

Modified by pleiades-1997

Helpful?

more options

Just an update:

Problem disappear after downgrade to Firefox 75.0 build 3 using apt-get install firefox=75.0+build3-0ubuntu1.

So this is an issue with 89.0.

Helpful?

more options

Chosen Solution

Such issues are usually caused by a problem with hardware acceleration in Firefox, but you wrote that disabling this feature didn't work. You did close and restart Firefox as this is mandatory ?

You can also try to disable WebRender via the about:config page.

Helpful?

more options

pleiades-1997 said

Did you have the open H.264 DLLs installed prior to upgrading Firefox (built from www.openh264.org)? Or download and installed from another source ? Secondly do you also have the issue on the checkboxes in the Firefox's "Settings" page ? (see second screendump from https://support.mozilla.org/en-US/questions/1338943

i'll be honest, i don't know, because i didn't consciously or knowingly install it at any point from any source. and my checkboxes didn't look like that.

cor-el said

Such issues are usually caused by a problem with hardware acceleration in Firefox, but you wrote that disabling this feature didn't work. You did close and restart Firefox as this is mandatory ? You can also try to disable WebRender via the about:config page.

that actually turned out to be the problem - when i turned it off, i failed to consider closing/reopening firefox (i'm making myself look like a n00b... perhaps that simply means i am one). i realized this mistake, then i tried turning the hardware acceleration BACK off, closed/reopened, and now that i've watched + waited a couple days i can confidently say my problem appears resolved. though if it eventually occurs again, i'll try your second idea.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.