Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

delete search in address bar

  • 3 replies
  • 1 has this problem
  • 25 views
  • Last reply by cy6566

more options

Hello How to delete the search in the address bar. please. Thank you

Hello How to delete the search in the address bar. please. Thank you

Chosen solution

Hi, can you try on this method see whether can solve your problem:

1. Go to menu -> Click Settings -> Click Search

2. You will see Search Suggestions -> Uncheck the Provide search suggestions

Read this answer in context 👍 0

All Replies (3)

more options

Hi, you can try this method:

Clearing all items in the address bar history 1. Click on the menu button -> Click History.

2. Click Clear Recent History... to open the dialog window.

3. In the Clear Recent History window, set Time range to clear: to Everything.

4. To remove browsing history, make sure Browsing & Download History has a check mark next to it. To remove Search history -> check the box next to Form & Search History.

5. To clear all items in the address bar history, click OK.

You can refer this two website: https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions

more options

Thanks cy6566.

I did what you told me. .Unfortunately nothing has changed.

When I write in the mid-screen search window, the writing displays at the top of the address bar.

more options

Chosen Solution

Hi, can you try on this method see whether can solve your problem:

1. Go to menu -> Click Settings -> Click Search

2. You will see Search Suggestions -> Uncheck the Provide search suggestions

Modified by cy6566