Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Newest Firefox ruined the search function...help!

  • 2 replies
  • 1 has this problem
  • 3 views
  • Last reply by Waterfaery

more options

I always used the original Firefox search as my home page; one simple little panel in the middle of the page with a quick and easy search feature. I loved it. The latest version of Firefox has ruined it. Now we are forced to search from the address bar. I hate, loathe, and despise doing a search from the address bar. It is an A-1 nightmare. After you type one letter, it stops registering what you type and throws up a ridiculously long list of the web pages you've visited. Type another letter, and you have to go through this mess again. It makes for an absurdly slow search and never actually gets you to what you're searching for. I wound up with search results that weren't even related to each other much less related to what I was searching for. After one day of use, I'm so frustrated with this feature that I'm opening Google to do the search.

How do we reset this new version of Firefox to only search from the Firefox homepage search box and not go anywhere near that address bar? Or do I have to uninstall the latest update to get Firefox to function properly again? Even if it's an add-on that forces the search to where it belongs...anything!

Chosen solution

There is a preference for this but it does take a bit of work to find it because of the unusual name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

More info on about:config: Configuration Editor for Firefox.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

There is a preference for this but it does take a bit of work to find it because of the unusual name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

More info on about:config: Configuration Editor for Firefox.

Helpful?

more options

Yes!! Thank you so much! That was beyond annoying.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.