Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Help me get rid of the stupid and ugly Tab bar on newest Firefox

  • 9 replies
  • 1 has this problem
  • 36 views
  • Last reply by rob39lee

more options

Please help me get rid of the stupid and ugly Tab bar space on newest Firefox. I hate Tabs and now there is a big space above the address bar for Tabs. I have looked everywhere for a way to turn it off like it has been since Tabs came out. I only want new windows if I want a new window.

If I can't turn that huge space gap off is there any way to go back to what I had before the last update without messing everything up? Why did someone decide to make the browser window smaller and waste that space by making the browser bigger....

Sorry if I sound cranky but, I started using Netscape Navigator 1.0 and every version since and this is the worse thing that has ever been done to a browser... Thank you for any help you can give me!

Attached screenshots

Chosen solution

Sorry if my replies gonna show up multiple times, but it is waiting for approval as it contained external link. Anyway, here it is again: I coudn't find any settings in about:config, but I tried this and it works (it's gonna permanently hide the tab bar!):

put this line into the userChrome.css

#TabsToolbar { visibility: collapse !important; }

Be sure the title bar is visible, otherwise you gonna loose your min/max/close buttons, left with an empty bar on the top.

Also there is an extension Hide Tabs by Afnan Khan, you might give a try.

Ohhh, and don't forget to set the toolkit.legacyUserProfileCustomizations.stylesheets to true in about:config

If you don't know much about userChrome.css - go to your profile folder c:\Users\YOURUSERNAME\AppData\Roaming\Mozilla\Firefox\Profiles\SOMETHINGRANDOM.default\ create a folder "chrome" right click and create a new txt file, rename it userChrome.css. Now you can put the line above into it.

Read this answer in context 👍 1

All Replies (9)

more options

Downgrade to Firefox ESR, see my answer on my own post: https://support.mozilla.org/en-US/questions/1338596

Helpful?

more options

gsfc12 said

Downgrade to Firefox ESR, see my answer on my own post: https://support.mozilla.org/en-US/questions/1338596

Thank you for the help but, that stuff is way over my head..

Is there something in "About:config" that I can change to get rid of the stupid tab showing on a page when only one thing is open? I swear the there was a place to uncheck if you didn't want to see that tab stuff... SeaMonkey will still let you hide that junk..

Hide Tab Garbage = YES!

Helpful?

more options

deleted

Modified by gsfc12

Helpful?

more options

deleted

Modified by gsfc12

Helpful?

more options

Chosen Solution

Sorry if my replies gonna show up multiple times, but it is waiting for approval as it contained external link. Anyway, here it is again: I coudn't find any settings in about:config, but I tried this and it works (it's gonna permanently hide the tab bar!):

put this line into the userChrome.css

#TabsToolbar { visibility: collapse !important; }

Be sure the title bar is visible, otherwise you gonna loose your min/max/close buttons, left with an empty bar on the top.

Also there is an extension Hide Tabs by Afnan Khan, you might give a try.

Ohhh, and don't forget to set the toolkit.legacyUserProfileCustomizations.stylesheets to true in about:config

If you don't know much about userChrome.css - go to your profile folder c:\Users\YOURUSERNAME\AppData\Roaming\Mozilla\Firefox\Profiles\SOMETHINGRANDOM.default\ create a folder "chrome" right click and create a new txt file, rename it userChrome.css. Now you can put the line above into it.

Helpful?

more options

Thank you!!!!!

Modified by rob39lee

Helpful?

more options

gsfc12 said

Sorry if my replies gonna show up multiple times, but it is waiting for approval as it contained external link. Anyway, here it is again: I coudn't find any settings in about:config, but I tried this and it works (it's gonna permanently hide the tab bar!): put this line into the userChrome.css #TabsToolbar { visibility: collapse !important; } Be sure the title bar is visible, otherwise you gonna loose your min/max/close buttons, left with an empty bar on the top. Also there is an extension Hide Tabs by Afnan Khan, you might give a try. Ohhh, and don't forget to set the toolkit.legacyUserProfileCustomizations.stylesheets to true in about:config If you don't know much about userChrome.css - go to your profile folder c:\Users\YOURUSERNAME\AppData\Roaming\Mozilla\Firefox\Profiles\SOMETHINGRANDOM.default\ create a folder "chrome" right click and create a new txt file, rename it userChrome.css. Now you can put the line above into it.

I can't thank you enough! Now my browsers don't look broken, I have 3 PC's and now I can fix the other two so they don't look broken too. My wife will be happy too, she didn't like the new tab thing at all! Thank you!!!!!

Helpful?

more options

You are welcome. Don't forget, if a link opens in a new tab in the background (maybe some setting can disable it), it will be there, but invisible. This script does not disable the tabs, just hides them.

Helpful?

more options

Is there any chance they undid this Tabs in all windows in the last update? I liked what it did with the tabs at first but, when you highlight a word, right click and hit Search for it, it opens the search in the same window you are in and you lose the text you typed in on the page you are on. Is there a way to change it so when I hit search it will open a new window? I would love that much better than search opening a new tab..

Modified by rob39lee

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.