Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"System theme" is not enabled

  • 15 replies
  • 3 have this problem
  • 58 views
  • Last reply by jscher2000

more options

Hello.

"System theme" is not enabled in theme management. Is this a specification? Is it a bug?

Best regards

All Replies (15)

more options

Hi, do you mean if you click its Enable button, it doesn't enable? Or it doesn't actually look like your system theme?

Helpful?

more options

Thank you for answering.

Clicking Enabled does not change the theme. The active tab will be white, but the other tabs will remain white. If it's a system theme, the other tabs should be black.

Helpful?

more options

Hi, did you try checking on your system theme? Perhaps the system itself is not dark themed?

Helpful?

more options

If you prefer the dark navy background from the earlier version, you can use an add-on theme to restore that color. Does this help?

https://addons.mozilla.org/firefox/addon/photon-colors/

Helpful?

more options

Thank you for answering.

I have confirmed the system theme. Light mode and dark mode reflect the settings, but only the system theme does not change. The colors of the light theme and the system theme are the same.

Helpful?

more options

Thank you for answering.

I want to enable the system theme if possible. Ideally, the colors should match the Windows system.

Helpful?

more options

Hopefully someone else has some ideas, I don't know of any way to modify how the built-in themes work.

Helpful?

more options

Thank you for answering.

Since the display has been updated with the new version, I also assume the possibility of problems associated with it.

Helpful?

more options

Since I updated Firefox this morning I am finding the screen too bright to work with. There is no difference between thr System Theme and the Light Theme. I tried to send the message through Feedback but all I see is "Ideas"

Is someone able to reactivate the previous Theme which I presume is System Theme, please?

Helpful?

more options

geneann said

Since I updated Firefox this morning I am finding the screen too bright to work with. There is no difference between thr System Theme and the Light Theme. I tried to send the message through Feedback but all I see is "Ideas" Is someone able to reactivate the previous Theme which I presume is System Theme, please?

The previous theme with the dark navy background (at least on Windows 10) was called the "Default" theme. I am not aware of any adjustments to built-in themes, but you can supplement them with add-on themes. This is the one I mentioned earlier:

https://addons.mozilla.org/firefox/addon/photon-colors/

Helpful?

more options

Thank you for your reply.

I do not want to play around with addons etc, I would just like the Default theme back please.

If the Default is not the System Theme, please let me know how to revert to Default?

Thanks

Modified by geneann

Helpful?

more options

Thank you for answering.

Isn't this a bug? If it's not a bug, I think the only way is to use another theme.

Helpful?

more options

akiokwbt said

Thank you for answering. Isn't this a bug? If it's not a bug, I think the only way is to use another theme.

I don't know whether the System theme is working as designed or is broken. Either way, a change is unlikely for until the next release, so you may want to use another theme until then.

Helpful?

more options

The problem with System Theme being the Light Theme in version 89 does not appear to have been fixed in version 90, as the Bug corrections do not include it, and the System Theme is still the Light (all white) Theme.. How can we have this problem designated a BUG in an attempt to have it fixed please?

Helpful?

more options

Hi geneann, I still don't know whether it is working as designed or is broken. Therefore, I do not know whether it is a bug or simply a design a lot of people don't like.

If you want to submit a formal bug report, the system for that is over here: https://bugzilla.mozilla.org/

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.