Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Incorrect presentation of icons in an online crossword page

more options

I use the following crossword site:

https://thenewdaily.com.au/puzzles/quiz-crossword/

When I open it with Firefox, including the latest version, the "Help" icons are replaced by mathematical symbols. If I use Microsoft Edge, the Help icons are there.

Any feedback will be appreciated.

Cheers, "Sunbury Bob"

Attached screenshots

Chosen solution

Hi Bob, this could be caused by setting Firefox to ignore the fonts pages tell it to use, or blocking web fonts (also known as remote fonts or downloadable fonts).

Here are a couple things to check:

Extensions

Some extensions block webfonts, also known as remote fonts. For example, the popular uBlock Origin and NoScript extensions can do that.

Font Settings

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Command+r or the circling arrow button, to see any difference)?


There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Was it any of those things?

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi Bob, this could be caused by setting Firefox to ignore the fonts pages tell it to use, or blocking web fonts (also known as remote fonts or downloadable fonts).

Here are a couple things to check:

Extensions

Some extensions block webfonts, also known as remote fonts. For example, the popular uBlock Origin and NoScript extensions can do that.

Font Settings

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Command+r or the circling arrow button, to see any difference)?


There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Was it any of those things?

Helpful?

more options

Thank you very much. It took me a while to find the "Advanced..." font settings in the new version of Firefox, but once I did, I was able to click in the "Allow pages to .... et.al" box and low and behold, the relevant icons/buttons appear where they should. I really appreciate you taking the time to solve my problem. At the risk of overstaying my 'welcome' (to coin a phrase), do you know anything about Windows 10?

Helpful?

more options

Robert Hill said

At the risk of overstaying my 'welcome' (to coin a phrase), do you know anything about Windows 10?

I use Windows 10, but I don't spend a lot of time researching it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.