Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Loading pages, especially from links in other pages FF88, iMac M1

  • 4 replies
  • 1 has this problem
  • 20 views
  • Last reply by kahn40

more options

On my iMac M1 running Big Sur 11.4, Firefox 88.0.1 often does not load a link or flashes info but then shows a blank page. The problem is more frequent when moving between pages—most Google News sites work, for example, but secondary sites often do not. I've tried relaunching FF, turning off all Add-ons and turning off all Add-ons and relaunching. Even restarting the computer. No change. The pages work on Chrome and Safari. My temporary (I hope) solution is to use another browser but I LIKE Firefox.

All Replies (4)

more options

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia


If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

Helpful?

more options

I started Firefox in Safe mode and that did not help. I restarted the computer in Safe Mode and that did not work. (This is not quite as easy as it looks. Apple has changed the procedure and the "Continue" prompt the Safe mode website describes is not present until you choose a disk. Apple should probably say this.) (One web page that is interesting is my weather underground (wunderground.com) 10 day forecast. The page loads but the forecast does not.)

Helpful?

more options

Chosen Solution

Helpful?

more options

The first of the links, which prompted me to create a new profile.in file in the Library, worked on a couple of links that were problems.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.