Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cursor really small in firefox

more options

So out of a sudden my cursor is like really small in firefox https://i.imgur.com/hHls0Hf.png thats the google page with the cursor in firefox https://i.imgur.com/RuFlp8W.png thats the same but in edge

I already tried safe mode and a fresh reinstall of firefox

yet the problem is there there, and makes Firefox not really good to use, since you just lose the cursor on white sites

Anyone knows how to fix this?

Chosen solution

·´¯`·...¸>-)))º> ~dbben said

seek the mouse settings in win 10 to resize the mouse. maybe under accessibility control panel?

Resizing the cursor there actually solved the problem!!! Thank you so much! Didnt even know such a setting exists

Read this answer in context 👍 0

All Replies (12)

more options

Hmm, I'm not aware of a Firefox setting for the size the mouse pointer icon/graphic (or whatever that arrow should be called).

Do you use an extremely high resolution display?

Helpful?

more options

jscher2000 schrieb

Hmm, I'm not aware of a Firefox setting for the size the mouse pointer icon/graphic (or whatever that arrow should be called). Do you use an extremely high resolution display?

I use a 27" 2560 x 1440 Monitor

And the problem is also in the firefox windows like here: https://i.imgur.com/htoqi5r.png

Helpful?

more options

I haven't seen this before. I assume it is somehow related to resolution, but your resolution isn't too extreme, so there must be some other factor.

Could you test whether this problem also exists in the beta of Firefox 89? The safest way to check that is to install the Firefox Developer Edition alongside your regular Firefox. See: https://www.mozilla.org/firefox/developer/

Helpful?

more options

jscher2000 schrieb

I haven't seen this before. I assume it is somehow related to resolution, but your resolution isn't too extreme, so there must be some other factor. Could you test whether this problem also exists in the beta of Firefox 89? The safest way to check that is to install the Firefox Developer Edition alongside your regular Firefox. See: https://www.mozilla.org/firefox/developer/

Okay, it works in the dev version: https://i.imgur.com/1tPit8d.png

Helpful?

more options

seek the mouse settings in win 10 to resize the mouse.

maybe under accessibility control panel?

Helpful?

more options

Chosen Solution

·´¯`·...¸>-)))º> ~dbben said

seek the mouse settings in win 10 to resize the mouse. maybe under accessibility control panel?

Resizing the cursor there actually solved the problem!!! Thank you so much! Didnt even know such a setting exists

Helpful?

more options

We are glad to help !

Helpful?

more options

·´¯`·...¸>-)))º> ~dbben said

seek the mouse settings in win 10 to resize the mouse. maybe under accessibility control panel?

That only helps with a few cursors/pointers. Firefox appears to use it's own, user-hostile, pointers for things like the image plus/minus magnification. These impossible-to-differentiate pointers do not change with the windows settings. Plus the windows-enlarged text brackets make it much harder to precision-select text.

Helpful?

more options

Does increasing layout.css.devPixelsPerPx has any effect ?

You can set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. Adjust its value in 0.1 or 0.05 steps (1.1 to enlarge or 0.9 to reduce) until icons or text looks right. Make sure not to use values too large or too small.

  • modifying layout.css.devPixelsPerPx affects user interface and webpages (global zoom)

Firefox has a Zoom section in Settings to set the default zoom level for webpages.

  • Settings -> General -> Language and Appearance -> Zoom

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Helpful?

more options

cor-el schrieb

Does increasing layout.css.devPixelsPerPx has any effect ? You can set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. Adjust its value in 0.1 or 0.05 steps (1.1 to enlarge or 0.9 to reduce) until icons or text looks right. Make sure not to use values too large or too small.
  • modifying layout.css.devPixelsPerPx affects user interface and webpages (global zoom)
Firefox has a Zoom section in Settings to set the default zoom level for webpages.
  • Settings -> General -> Language and Appearance -> Zoom
You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

This didnt change anything I still have to manually open the windows settings, change the size there to any size, open firefox with that large cursor click in firefox, and scale it back Then it works

Helpful?

more options

You can try to clear the startup cache via the "Help -> More Troubleshooting Information" (about:support) page.

Helpful?

more options

cor-el schrieb

You can try to clear the startup cache via the "Help -> More Troubleshooting Information" (about:support) page.

Also didnt help

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.