Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't play videos on youtube when I'm signed into my account

  • No replies
  • 1 has this problem
  • 2 views
more options

Firefox 78.10.1 esr 64 bit Windows 10.0.19041.985

This question was originally asked here, https://support.mozilla.org/en-US/questions/971100 , but has since been archived. YouTube videos load when not logged in, but will not load when logged into my YouTube account. They produce the following error:

  • An error occurred. Please try again later. (Playback ID: [random generated hash])

The advice offered in the cited Mozilla Support article assumes the problem is with Firefox, and had users delete their entire SQL-Lite cookie database, even though users reported that the error persisted after a clean install. Yes, it can sometimes be a cookie database issue, but this time, MAY 2021, it's a problem with YouTube's ad loader. This has happened before [1]. The work around until they fix it is to click on any suggested video on the same page. As soon as it starts to load, hit the browser's back button, and the error producing video will load.

[1] https://support.google.com/youtube/thread/10329866/consistently-getting-an-error-occurred-please-try-again-later-playback-id-on-all-videos?hl=en

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.