Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cookies required to use Firefox

  • 16 replies
  • 1 has this problem
  • 113 views
  • Last reply by bradhaack

more options

Getting Cookies required to use Firefox To continue signing in using Firefox, allow cookies to be stored on this device. You might see this screen more than once.

message after the upgrade and it's very frustrating that mozilla push these updates without testing them properly. What I did -Tried adding an exception with allow for Cookies -Changed Standard mode to Custom - Tried with private browsing - Cleared cache - Switched off Tracking and protection for this website as well as opencart.zendesk.com

Nothing helped. On chrome it works. How to fix this ?

It is really irritating when things does not work seamlessly. I've been using FF for more than a decade and got used to it now I can't shift to Chrome kindly help me resolve this

Attached screenshots

Chosen solution

Oh I see. Zendesk is framed. Right-click in the login form area, click This Frame, then click Open Frame in New Tab. Then you can set permissions for the framed site instead of the outer site.

Read this answer in context 👍 1

All Replies (16)

more options

That looks familiar. There is some site where I've started getting that recently and I have to click the stupid Continue link every time. As far as I can tell, it's shown to all Firefox users regardless of whether cookies are enabled or not. Just stupid and annoying web design, in my humble opinion, to not even remember that they showed me this message before (hey, set a cookie, that's what they're for).

more options

jscher2000 said

That looks familiar. There is some site where I've started getting that recently and I have to click the stupid Continue link every time. As far as I can tell, it's shown to all Firefox users regardless of whether cookies are enabled or not. Just stupid and annoying web design, in my humble opinion, to not even remember that they showed me this message before (hey, set a cookie, that's what they're for).

Hi But clicking continue did not resolve the issue

more options

Oh, it worked for me on whatever site I had that problem on.

What happens when you click Continue -- it returns to the page?

Can you share a link to the problem page if it's public (i.e., doesn't require using an account)?

more options

jscher2000 said

Oh, it worked for me on whatever site I had that problem on. What happens when you click Continue -- it returns to the page? Can you share a link to the problem page if it's public (i.e., doesn't require using an account)?

Yes, it retuens to the same page. URL is https://support.opencart.com/hc/en-us https://support.opencart.com/hc/en-us

more options

Chosen Solution

Oh I see. Zendesk is framed. Right-click in the login form area, click This Frame, then click Open Frame in New Tab. Then you can set permissions for the framed site instead of the outer site.

more options

(That's also necessary if you want to save a login for a framed Zendesk site.)

more options

jscher2000 said

(That's also necessary if you want to save a login for a framed Zendesk site.)

Hi

That fixed it. Thank you. So I have to do this everytime?

more options

This could be a feature of Zendesk framed sites. Opening them in their own tab is the easiest way to manage their permissions and saved logins, but hopefully those settings also will be recognized in the frame going forward.

more options

Is this ongoing issue a bug or a feature? It certainly gets in the way.

more options

sparrowtwo said

Is this ongoing issue a bug or a feature? It certainly gets in the way.

Are you having the problem in a framed page like the Zendesk help site examples? If there is a different scenario, please start a new question with more details:

https://support.mozilla.org/questions/new/desktop/form

more options

Yes it is a helpdesk but I'm not positive it's zendesk...likely it is.

more options

Confirmed, zendesk

more options

sparrowtwo said

Confirmed, zendesk

After setting the permissions or saving the login for Zendesk (using the right-click > This Frame > Open in New Tab trick), you should be able to use Zendesk embedded in the other company's page. Does that work for you?

If it stops working after you exit/restart Firefox, there could be a setting or file issue with retaining site permissions (like cookie permission).

more options

When I tried that, as the page suggests, it opened a completely blank page. I should have mentioned this before, sorry.

more options

sparrowtwo said

When I tried that, as the page suggests, it opened a completely blank page. I should have mentioned this before, sorry.

So the sequence of events is:

(1) Open the company help page.

The framed area shows the Cookies Required message.

(2) Right-click in the framed area, This Frame, Open Frame in New Tab.

The new tab shows a blank page instead of showing the content that was in the frame.

Hmm, that shouldn't happen. Usually there will be a lot of parameters on the URL. In the original example, the address of the framed page is:

https://opencart.zendesk.com/auth/v2/login/signin?return_to=https%3A%2F%2Fsupport.opencart.com%2Fhc%2Fen-us&theme=hc&locale=en-us&brand_id=3022446&auth_origin=3022446%2Ctrue%2Ctrue&browser=firefox&request_cookie_access_state=request_access

Does your new tab show that kind of URL? Unless you are using OpenCart support, the left part of the URL will be different (it will show something like the account name of the company with Zendesk).

more options

sparrowtwo said

When I tried that, as the page suggests, it opened a completely blank page. I should have mentioned this before, sorry.

I get a blank page too, but I delete everthing trailing the website url and that gets me to the main page and I'm logged in