Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is sending me to https://www.social-searcher.com/facebook-search/

more options

Hi, Firefox keeps defaulting to https://www.social-searcher.com/facebook-search/ when I have set my default to google.com. Anyone have an idea how to fix this? Thank you!

Chosen solution

Hi Sally,

open Firefox in safe mode

open menu -> help -> Restart with add-ons disabled 

shortcut: Alt, H, R

use Firefox normally and check that you are facing the Search issue there.if you are facing issue in normal mode only then some add-ons is causing that issue, else try resetting Firefox https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems use the link and follow the steps shown. first try Refreshing if you fix you problem then skip resetting and then try resetting

Read this answer in context 👍 0

All Replies (3)

more options

Type about:preferences#search<enter> in the address bar. You can select any search engine to be your default from here.

You can also remove any engine from here.

more options

Hi Fred, My default is Google in Firefox, yet it keeps opening facebook search. Some wires are crossed somewhere. Any suggestions? Sally

PS. The Firefox browser no longer allows me to take a screenshot, the selection is missing. I used Grab.

more options

Chosen Solution

Hi Sally,

open Firefox in safe mode

open menu -> help -> Restart with add-ons disabled 

shortcut: Alt, H, R

use Firefox normally and check that you are facing the Search issue there.if you are facing issue in normal mode only then some add-ons is causing that issue, else try resetting Firefox https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems use the link and follow the steps shown. first try Refreshing if you fix you problem then skip resetting and then try resetting