Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

not save settings in about:config

  • 3 replies
  • 1 has this problem
  • 8 views
  • Last reply by TyDraniu

more options

"For those who use Firefox beta, Nightly and Adguard installed. Firefox does not accept Adguard user or system certificate. Trying to force Firefox to accept the certificate. To do this, look for the security.enterprise_roots.enabled flag in about: config and switch it to true. After in Adguard - Application settings, enable https filtering for Firefox. "

About two weeks ago, this item in the about: config settings in the nightly version ceased to be saved, I thought a bug, they will fix it ... I went to beta ... Today, this bug was apparently transferred to beta. In the same way, the item flies in the settings. Not sure after restart or over time.

But using a browser with an adguard certificate and the like is now problematic, re-register each time.

I won't tell you about other settings in about, but most likely they are also not saved by analogy after restarting.

I checked it on two smartphones.

Does anyone know what can be done, is there the same problem?

Can someone send a report to the developers? I kind of sent, but as we can see, there is no result. Maybe I wrote to them in the wrong place.

All Replies (3)

more options

Not sure about the reason of your problem but I also see that you don't use an user.js file. But one way to hopefully fix your problem would be to use an user.js file. Put all your about:config changes there in an user.js file and put it in the profile folder.

Helpful?

more options

Oh, sorry. We are talking about Firefox on Android. One device has a root, and the other does not. Without root, it is impossible to put something in the profile folder. The problem is tedious to solve at the application level. Previously, all about:config settings were saved well.

Helpful?

more options

Hi, this is a known issue. Devs are working on it. Plus there's a plan to add a switch for this preference in Secret settings.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.