Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not show all speakers as options in Google Voice

  • 5 replies
  • 1 has this problem
  • 12 views
  • Last reply by jscher2000

more options

Hello,

I've been a Firefox user as far back as the days of Phoenix. I've been using it as my main browser whenever possible on both Windows and Linux over that time.

I've also been a long time Google Voice user.

I've always had to work around an issue using Google Voice with Firefox. I have to switch the OS's default speaker device in order to get the call sound to play through an attached headset. Google Voice has a menu where I should be able to select from the available devices attached to the system but under Firefox I am only able to see System speaker default device.

Is this a known issue? Is there any workaround? It's fairly annoying to have to switch this under the OS settings as it changes the behavior for all of my apps. I would very much prefer to be able to make this selection at the application (Firefox) level.

Thanks, Dave

Attached screenshots

Chosen solution

I'm not sure why this is disabled, it might be buggy, but this change will allow pages to query and (hopefully) specify output devices:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste media.setsinkid.enabled and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

Read this answer in context 👍 1

All Replies (5)

more options

I wanted to give a little more detail on this issue. I found another online app that demonstrates the same behavior.

https://webrtc.github.io/samples/src/content/devices/input-output/

I'm attaching a screenshot of the page. In the screenshot you can see that I'm able to select the "Audio input source", but not the "Audio output destination".

This is the exact behavior I see in Google Voice.

Helpful?

more options

Chosen Solution

I'm not sure why this is disabled, it might be buggy, but this change will allow pages to query and (hopefully) specify output devices:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste media.setsinkid.enabled and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

Helpful?

more options

That did it! Thank you so much!

Helpful?

more options

I had also been asking about this in the general channel in chat.mozilla.org. Someone there had this to add.

"setSinkID is the way Chrome implements it is not very privacy friendly. The Fx implementation behind that pref is waiting for the implementation of selectAudioOutput() which is a lot more privacy friendly. The plan Is to ship these two APIs together."

Helpful?

more options

Thanks, that is good to know.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.