Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Disable App Update" application active in Firefox

  • 4 replies
  • 1 has this problem
  • Last reply by Scribe

more options

I found in 87.0 and now 88.0 that even after uninstalling and installing a new version, there is after clicking Menu/Options a message on top of the window:

" ! Your browser is controlled by your organisation" This is not true, there is no organisation on this PC. After clicking the link here is a new window saying there is a application active that is called "Disable App Update". After clicking "documentation" on the left side there opens a list of applications to modify the operation of Firefox. When clicking the Disable App Udate there opens a application text with on top GitHub and activities from M.Kaply Show/ Home Button Policy Strange that it says Disable Firefox Updates. Is this application installed by you? Are you perhaps 'the organisation'? Please let me know if this is safe or not.

BR Hans

All Replies (4)

more options

Hi, that happens when a Policy has been added, which in your case is DisableAppUpdate. Is your PC in an enterprise environment (a company) and not your own personal one? You can find it by going to C: Drive > Program Files > Mozilla Firefox, then look for a folder named distribution, which will contain the Policy file. Deleting the file or the distribution folder then restarting Firefox should remove it, but if it's in a company's PC, you should probably talk to your IT department first. If it's your own personal PC something/someone must have added the file and folder which seems very strange. The GitHub link - this one I assume: https://github.com/mozilla/policy-templates/blob/master/README.md# and M.Kaply are genuine.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

more options

Thanks for your reply. Checked the "C: Drive/PF/Mozilla FF but there is no folder called 'distribution' in there. What's next? And for your info this is not a company computer but a private one and no one can touch it. And FF was normally from the Mozilla servers downloaded. So someone (have no clue at all) added it. After discovering it, I already uninstalled the software and downloaded a new version and installed that one but the DisableAppUpdate was still there. Hope someone can help me out. I am standard very careful with strange situations and have a tightly secured computer wich I service regularly. Hope someone can help me with removing it.

Helpful?

more options

If there's no distribution folder, you have to check in the registry under HKLM or HKCU -> \Software\Policies\Mozilla\Firefox

Helpful?

more options

Yes as TyDraniu said, you will need to check the Registry: Open regedit by entering it into your PCs search box. Next, navigate through HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ then select and right click > Delete, any policy that is there, and if necessary you can also delete \Mozilla and \Firefox. You might need to restart Firefox and possibly your PC afterwards. Note: if you aren't confident with editing the Registry, I suggest you create a Windows Restore Point first, so can roll back if you make a mistake.

Something has created that policy on your PC - it's intended to prevent all Firefox updates, so if the policy comes back in the Registry after you have deleted it, then most likely a program that you installed on your PC when this started is causing it. If you didn't install anything yourself, then it could be caused by malware, so you can try these free programs to scan for malware, which work with your existing antivirus software:

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.