Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Interaction of email alias and Reply/Reply-All

more options

I'm having trouble having my second email address cc'd when I reply-all.

For historical reasons my main email is like bob2@domain.org but I like to use bob@domain.org, so we set up "bob@domain.org" as alias and I set up TB as:

Account name: bob@domain.org Your name: Bob Foobar Email Address: bob2@domain.org Reply-to Address: bob@domain.org

If I send an email to some addresses, and they reply, TB offers my a Reply (if there's one correspondent) or else Reply-All that goes to bob@domain.org and does not include bob2@domain.org. That's perfect.

But replies from people using Yahoo and Gmail trigger TB to offer Reply-All, even if there's one recipient, and my bob@domain.org is included in the reply-all.

So, if I email Abe@yahoo.com, and Abe replies; TB then allows me to click Reply-All and the reply goes to Abe@yahoo.com and bob@domain.org. That's semi-manageable when I'm corresponding with one person, but when I'm corresponding with a group, I need to reply-all and I often forget to delete my own email and get a copy, which is confusing to people and annoying to me. It's annoying enough to want to change my email to avoid this issue, but this is happening on a fresh install of the latest TB on a and Windows 10. I didn't have this issue yesterday with a recent version of TB on a W7 computer. I think I solved this years ago on my old computer, but I cannot recall how. I noticed this issue because I replied to a group and accidentally included myself today, wheras I had not done so earlier this week with my old TB.

I notice that if I view source that the replies that work fine (do not add in my email alias) include the Reply-All header and those that trigger the bad behavior do not include it (that's the source of the reply to my email). But I cannot tell Yahoo and Gmail to change things. Either there's something I need to do to get them to include that header, or I need to configure TB to be more robust about this issue.

Here's what I have done (none of which have helped): 1. Set the reply-all (as shown above) 2. Done 60 minutes of reading and googling about this issue 3. Managed identities, edited the identity, and under Private Data added bob*@domain.org to "Reply from this identity when delivery headers match" 4. Added myself to contacts as bob@domain.org with bob2@domain.org as an alternative email. 5. Changed the "Description" of the outgoing SMTP settings to "<Bob Foo> bob@domain.org" 6. Changed the "Description" of the outgoing SMTP settings to "bob@domain.org" 7. Changed the "Description" of the outgoing SMTP settings to "bob2@domain.org" 8. Looked for a "Smart Reply" button (I don't see one)

Chosen solution

Alan Mead said

I set up TB as: Account name: bob@domain.org Your name: Bob Foobar Email Address: bob2@domain.org Reply-to Address: bob@domain.org

I may have solved this. Looks like changing my email above to bob@domain.org fixes the issue.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Alan Mead said

I set up TB as: Account name: bob@domain.org Your name: Bob Foobar Email Address: bob2@domain.org Reply-to Address: bob@domain.org

I may have solved this. Looks like changing my email above to bob@domain.org fixes the issue.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.