Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

search generates "excessive traffic" page

  • 3 replies
  • 1 has this problem
  • Last reply by Naheed

more options

Today, when I enter any search term, Firefox puts up a new page saying there is "excessive network traffic" from my computer. The search is for anything, such as "Firefox contact" or "grow azalea". Is this a feature in a new Firefox update?

All Replies (3)

more options

Is it Firefox itself, or a search engine?

One way to check is by trying to go to a random link, like a bookmark that isn't a search. E.g., going to https://www.mozilla.org/ and seeing if it still gives you the error.

If it doesn't, then it's probably an issue with your search engine. If it does, then it might be with Firefox itself.

You could also post a screenshot of the page you get, that would help people in this forum know what the issue is.

If it still shows up, try Safe Mode. There's a copy-paste template that tells you how to do that. I'll insert it below

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button Fx57Menu, click Help Fx57Help and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Fx68SafeMode

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Helpful?

more options

Is that the Google page which forces you to enter a CAPTCHA?

Helpful?

more options

Hello, I think you are talking about Google search results. If you can do the same from any browser, Google will ask for entering the CAPTCHA and after that, you will be able to perform your search again. So, it is not Firefox issue.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.