Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFox is schizophrenic! How do I stop it from switching languages on my PC?

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

I have just had my PC updated to Win 10 at a neighborhood PC shop here in Germany. But now I can't get all the screens to speak in English. I have placed a check-marke on several Menus that ask for a language preference. But it doesn't seem to help. What I have been getting when Mozilla opens up with a split screen is, one screen is in English and the other is in German. I suspect the cause for this is because my e-mail address has a '.de' at the very end, which is Germany. So It looks to me like there is a s/w problem at your end. The s/w keeps looking at my address, instead of the screens where I have asked it to write to me in the English language. Is there a fix for this problem yet? Or must I wait some more before it get's fixed.

I have just had my PC updated to Win 10 at a neighborhood PC shop here in Germany. But now I can't get all the screens to speak in English. I have placed a check-marke on several Menus that ask for a language preference. But it doesn't seem to help. What I have been getting when Mozilla opens up with a split screen is, one screen is in English and the other is in German. I suspect the cause for this is because my e-mail address has a '.de' at the very end, which is Germany. So It looks to me like there is a s/w problem at your end. The s/w keeps looking at my address, instead of the screens where I have asked it to write to me in the English language. Is there a fix for this problem yet? Or must I wait some more before it get's fixed.

All Replies (1)

more options

You can try to clear the startup cache via the "Help -> Troubleshooting Information" (about:support) page.