Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox playing video instead of asking me to download it.

more options

Hi. I would like firefox to download certain .mp4 videos. However, it plays inside firefox instead.

How can I configure this? Thank you!

Chosen solution

Hi, if you open a .mp3 or .mp4 directly in a tab, Firefox plays it using the "stand alone" media player. You can disable the stand alone media player so Firefox will show a Download dialog instead. Here are the steps for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste media.play-stand-alone and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

If you need to turn it back on, return to that preference and double-click it to toggle it back to true (or you can use the controls on the right end of that row to switch/reset it).

Does that make Firefox do what you want it to do?

Read this answer in context 👍 1

All Replies (4)

more options

rhonearevyn.roque said

Hi. I would like firefox to download certain .mp4 videos. However, it plays inside firefox instead. How can I configure this? Thank you!

I use firefox browser on windows, btw.

Helpful?

more options

Chosen Solution

Hi, if you open a .mp3 or .mp4 directly in a tab, Firefox plays it using the "stand alone" media player. You can disable the stand alone media player so Firefox will show a Download dialog instead. Here are the steps for that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste media.play-stand-alone and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

If you need to turn it back on, return to that preference and double-click it to toggle it back to true (or you can use the controls on the right end of that row to switch/reset it).

Does that make Firefox do what you want it to do?

Helpful?

more options

jscher2000 said

Hi, if you open a .mp3 or .mp4 directly in a tab, Firefox plays it using the "stand alone" media player. You can disable the stand alone media player so Firefox will show a Download dialog instead. Here are the steps for that: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste media.play-stand-alone and pause while the list is filtered (3) Double-click the preference to switch the value from true to false If you need to turn it back on, return to that preference and double-click it to toggle it back to true (or you can use the controls on the right end of that row to switch/reset it). Does that make Firefox do what you want it to do?

Thank you so much for this. I don't know this one since I just moved to firefox 2 days ago from google chrome.

Helpful?

more options

No worries, everyone has questions when adjusting to a different browser.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.