Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

the image opening options

more options

hi all

i have problem with firefox browser as it keep show in the image opening option (open with) and i went to windows solution the solution clears all options and i added image viewer manually but after a while firefox came again without adding , like it forces windows to be one of the image opening options.

is there is option or setting to stop that?

please see the photo attached, hope i explain what i want clearly

thanks all

Attached screenshots

All Replies (3)

more options

From what I understand, this is more of a Windows issue than a Firefox issue.

The removal process involves tinkering with registry so proceed with caution: External support article: How to Remove Programs from the "Open With" Context Menu in Windows Check your registry again if Firefox option is reappearing.

Alternatively, you can make your image open in a default program so you can effectively skip using "Open with".

Helpful?

more options

strafy said

From what I understand, this is more of a Windows issue than a Firefox issue. The removal process involves tinkering with registry so proceed with caution: External support article: How to Remove Programs from the "Open With" Context Menu in Windows Check your registry again if Firefox option is reappearing. Alternatively, you can make your image open in a default program so you can effectively skip using "Open with".

thank you strafy for answering

yes you are right I followed one of the windows instruction to remove it once but it reapprear in less than a week

I have default viewer but sometime i need open with "paint" which usually first choice unless firefox reappear again then i keep clicking it quickly lol so it open with FF which annoy me

if it is windows issue thanks i will follow there, but if there is a choice in FF setting that avoid FF from being image viewer in windows 10 will be great

thanks again

Modified by ghazalo73

Helpful?

more options

it looks there is no solutions

now i need to make the steps in your link every other day

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.