Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird 78.9.0 not displaying "tools>options>ADVANCED>preferences tab

  • 8 replies
  • 1 has this problem
  • 60 views
  • Last reply by backspace1

more options

Hi, I cannot find "tools>options>ADVANCED>preferences tab. All TB help says it should be there but it is not. How can i find it?

Chosen solution

Thunderbird times out with "server timed out" message when sending larger attachments SOLVED. Some update change appears to have created this problem in the last 12 months or less.

How i did it.

Ignore all the stuff about Tools, Options, Advanced, Preferences. That has changed.

Go to Tools, Options and scroll down to CONFIG EDITOR at the bottom. Click that and click "I accept the risk" Paste this into the search field. mailnews.tcptimeout Right click and choose MODIFY. Change the value to 2000. Exit.

This solved my problem and can upload 19.7MB files which includes encoding so original file will have to be smaller depending on your service provider.

Pity TB does not have a popup warning before sending larger attachments including encoding when other email programs i have used do that.

Tutanota.com does that if you are interested.

Read this answer in context 👍 0

All Replies (8)

more options

What are you trying to achieve in the first place?

Helpful?

more options

Hi Christ 1,

Thank you for replying.

Problem: I have suddenly been having problems with sending larger email attachments. Contacted ISP who confirmed that i can send file sizes up to 20MB. Checked their server settings and all OK. I used to be able to do this in the past no problem.

They say that they have had issues with later TB updates causing this problem. Error message is "server timed out". I since found out that i can change the mail server timeout.

"sfhowes

   Top 10 Contributor

3/12/20, 9:52 PM Chosen Solution

In Tools/Options/Advanced/General/Config. editor, you can try changing mailnews.tcptimeout, but the main problem is that IMAP is not suited for large-scale uploading to the mail server. Besides timeouts, you may be subject to upload bandwidth limits, as e.g. with gmail."

To get there i only have tools, options. No advanced etc. Finally found i can go to "config" and do it that way. Now set to 200. Attachment size set to 20MB. Still get "server timed out" However eventually my test email to myself came through regardless. Huh? Unfortunately TB has no warning of file size popup before sending. (On the wish list?) So i have no way of knowing whether or not the email has gone to the recipient apart from checking out box. Bit of a pain.

So something HAS changed in TB as in the past no problem.

Elsewhere i found a suggestion to disable AV. I run Kaspersky AV. This worked as progress bar crept along VERY slowly for a 14.5MB file including encoding. I am extremely reluctant to turn off my AV while online.

All TB help suggestions keep saying tools, options, advanced, preferences to get to the deep settings etc. as you can see above 3/12/20 but i don't have that. I do have "Config" which is what i used but still have the same issue.

Has this changed?

Has a TB update caused the server to reply timeout?

The settings i have changed made no difference and were not required in the past.

No problems in the past with TB and Kaspersky. Have sent up to 19.4MB OK.

Sorry for the lengthy reply. Was trying to avoid that.

Cheers.

Helpful?

more options

Hi again,

Just found this. Does it have anything to do with my current problem? Technically above my abilities.

https://support.mozilla.org/en-US/questions/1281869

https://bugzilla.mozilla.org/show_bug.cgi?id=1618455

Helpful?

more options

a few issues; One is that mime encoding increases the size of files significantly, so a 20mb file on disk will not send as an attachment. MIME encoding as a rule of thumb increases your file size to about 140% of the original size. So from a practical point of view you are limited to significantly less that 20mb in attachments as the email and attachment makers up the sent limit. This has remained largely unchanged for decades.

Two, the Bugzilla bug you have located may impact if you are getting errors about being unable to save sent mail to the sent folder. For actual sending of the mail it is totally irrelevant.

Three the other support topic is describing exactly what you were told to do in this topic. It does not add anything useful.

Fundamentally the best way to speed mail on it's way is stop your anti virus from scanning outgoing mail! It has already said you have nothing it can detect, so scanning mail created on your system that it says it clean is really something of overkill. It is not as if malware self creates out of nothing.

Instruction on the Kaspersky site here https://community.kaspersky.com/kaspersky-total-security-14/how-do-i-turn-off-outgoing-mail-scanning-5573

Personally I have NO mail scanning enabled. It greatly reduces the problems I have sending and receiving mail without an serious side effects really.

Helpful?

more options

Hello Matt,

One is that mime encoding increases the size of files significantly, so a 20mb file on disk will not send as an attachment. MIME encoding as a rule of thumb increases your file size to about 140% of the original size.

140% ??. Everything i have read says approx. 33%. Are you saying they are wrong? https://serverfault.com/questions/189508/considering-mime-expansion-bloat-how-does-that-affect-settings-for-exchange-200.

I have successfully sent 19.4MB in the past using TB (see screenshot)

My ISP can handle up to 20MB as they have overhead to deal with the extras.

Something has changed somewhere.

I do appreciate your info and will look into Kas links you provided.

Just trying to use TB as i have in the past.

Cheers.

Helpful?

more options
Just trying to use TB as i have in the past.

Things change over time. There are better ways than email to send large files, e.g. you could give FileLink a try. https://support.mozilla.org/kb/filelink-large-attachments

Helpful?

more options

Thanks christ 1

Things change over time. There are better ways than email to send large files, e.g. you could give FileLink a try.

I have been uploading to cloud sites since this problem arose.

Using TB is quicker which is what i would like to do.

Helpful?

more options

Chosen Solution

Thunderbird times out with "server timed out" message when sending larger attachments SOLVED. Some update change appears to have created this problem in the last 12 months or less.

How i did it.

Ignore all the stuff about Tools, Options, Advanced, Preferences. That has changed.

Go to Tools, Options and scroll down to CONFIG EDITOR at the bottom. Click that and click "I accept the risk" Paste this into the search field. mailnews.tcptimeout Right click and choose MODIFY. Change the value to 2000. Exit.

This solved my problem and can upload 19.7MB files which includes encoding so original file will have to be smaller depending on your service provider.

Pity TB does not have a popup warning before sending larger attachments including encoding when other email programs i have used do that.

Tutanota.com does that if you are interested.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.