Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox fails to recognize my GPU's but other programs and browsers recognize it.

  • 1 reply
  • 1 has this problem
  • Last reply by TyDraniu

more options

Firefox fails to recognize my GPU's and uses my integrated GPU rather than my dedicated GPU. I'm using Kali Linux (usually alike Debian Sid on repository grounds), I'm invoking it using DRI_PRIME=1 environment variable because that's where my Radeon RX560 is but firefox opens with this warning on terminal:

[GFX1-]: More than 1 GPU from same vendor detected via PCI, cannot deduce device.

I've even tried nightly but it doesn't recognize the dedicated GPU either, my other GPU is a Radeon Vega 8. All other other programs on the system and even Chrome recognize my RX560. Using DRI_PRIME=4 (that's where my Vega 8 is located) launches the browser with the same warning and again uses the integrated GPU, I know which one is using because radeontop shows memory usage only on the integrated GPU.

I don't know if this isn't the right place to post this, if you know a better place please tell me. Thank you in advance.

Attached screenshots

All Replies (1)

more options

Can you file a bug on the https://bugzilla.mozilla.org/enter_bug.cgi ? Thanks.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.