Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

[Solved] FF87.0 font issue

  • No replies
  • 1 has this problem
  • 10 views
more options

FF87.0 on Win10, all addons deactivated.

Hi, it seems that over night, the font of Japanese text in my MediaWiki has changed from [this](https://i.imgur.com/fxV9rMr.png) to [this](https://i.imgur.com/1uI9c1h.png). I don't know why, since I didn't access the server files or changed anything around.

Over the course of troubleshooting, I figured out that it seems like the monospaced font is at fault. So I tried to change the font Firefox uses for *serif fonts* to MS Gothic (instead of standard TNR). This is despite using *monospaced font* in my user settings on the wiki.

I also opened FF on my laptop where it is still on 84.0.2 and everything looks as it should, with the same standard settings applied everywhere. So I'm 80% sure the last FF updated changed something. The missing 20% are because I only noticed this yesterday, but the update happened four days ago, right?

Also, on the old FF the fonts used are Courier New and Microsoft YaHei. On the new FF it's Courier New and SimSun. In the settings I have "Fonts for: Latin" and the standard fonts, so I don't know where YaHei and SimSun come from. When I change Serif: TNR to YaHei, it changes from SimSun to YaHei...

Edit: This thread solved it, actually: https://support.mozilla.org/en-US/questions/1277075

Short answer: Add Japanese to the preferred languages, leave everything else as it is.

Attached screenshots

Modified by Dennis

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.