Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

black block appears nothing

more options

dear people and fire fox i recently switched from crome to firefox. but now I get a black block on all the websites that I visit, which suddenly appears and later also disappears. tried everything and firefox customer service is hard to get to. so any idea is welcome.

Attached screenshots

All Replies (4)

more options

can you provide me/us with the url ? then we can see if we also get the same issue or not.


more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window


more options

~dbben zei

can you provide me/us with the url ? then we can see if we also get the same issue or not.

yes the website of the screenshot was

but i also have this problem when i open another website it doesn't really matter which website. And I do use add blocker but before I installed it this problem already occurred.


more options

Thanks Igor, for the link.

The website looks good on my end with my Firefox. I have attached a pic.

But off hand, not sure what the black box is meant to be. Maybe the form fields on the page?

I think you may need to tweek your FireFox. But not sure which tweeks you need to review.

Perhaps, look at the hardware acceleration feature, as the black box could be indicative of video graphics. Mine is disabled. (enter in url field: about:preferences )

Also, try deleting the specific cookies for that specific website, so that can be rebuilt by the site.


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.