Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is not working

more options

I have Firefox on a HP computer with windows 10 home. It is now starting to act up. Firefox will not open my gmail account or even let me search for Google to get to my emails that way. It will not open, not even the search result. Is something wrong with Firefox? Should I uninstall it? I get no error message.

Chosen solution

Hi, assuming that the problem is only with Gmail and not other sites, try turning off 'Enhanced Tracking Protection' for that site by clicking the shield icon at the left-hand end of the address bar while the page is loaded - Enhanced Tracking Protection in Firefox for desktop.

If that doesn't help, disable any ad blocker you may be using then reload the site.

Try deleting ALL references to Gmail. To do that, open the 3-bar menu > Library > History, then click the Show All History link at the bottom of the list to open the History-library window. Search for Gmail by typing it into the Search History field in the top-right corner. Now in the search results, right-click on Gmail, and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a few minutes to complete the deletion, then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox.


Hold down the Shift key when you start Firefox to start in Safe Mode. More - Diagnose Firefox issues using Troubleshoot Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hi, assuming that the problem is only with Gmail and not other sites, try turning off 'Enhanced Tracking Protection' for that site by clicking the shield icon at the left-hand end of the address bar while the page is loaded - Enhanced Tracking Protection in Firefox for desktop.

If that doesn't help, disable any ad blocker you may be using then reload the site.

Try deleting ALL references to Gmail. To do that, open the 3-bar menu > Library > History, then click the Show All History link at the bottom of the list to open the History-library window. Search for Gmail by typing it into the Search History field in the top-right corner. Now in the search results, right-click on Gmail, and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a few minutes to complete the deletion, then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox.


Hold down the Shift key when you start Firefox to start in Safe Mode. More - Diagnose Firefox issues using Troubleshoot Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

more options

Thank You. I did the delete reference to Gmail ( forget about this site). I had to sign in, but it now works.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.