Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Enabling cookies

  • 6 replies
  • 1 has this problem
  • 1009 views
  • Last reply by FredMcD

more options

I am asking this question in Safari browser as when I am in Firefox browser I cannot get this page it just goes around circles when trying to log in to any website it is saying enable cookies ? I have my cookies set at standard .!

Chosen solution

Did you allow third-party cookies? If disabled, there may be problems.


Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Read this answer in context 👍 0

All Replies (6)

more options

Chosen Solution

Did you allow third-party cookies? If disabled, there may be problems.


Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

I started firefox in safe mode and was able to log in to a website i then closed firefox which i presume was in normal mode ?

more options

Closing Firefox when in Safe Mode, then restarting, starts the browser normally. Is the problem still there? If so,


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

I still have this problem l tried logging into Amazon and got the message enable cookies also tried logging in to Hotmail and iCloud mail both I got wrong log in details I was right with my log in details for both mail accounts the instructions you have I don't know how to do ? If I can fix it I will dump Firefox browser.can I not just go to my extension in my adding and do what you are asking me to do ? the keys you ask me control Mac command shift A I don’t know how to press these keys ! I disabled all my addons and was able to log in two Amazon so what now ? I disabled all add-on and then closed FF and put them on one by one closing FF as I did that I was able to log on to websites the only add-on which caused a problem not logging on was forget me not addon so I think that as solved the problem unless you can suggest anything else ?>

Modified by crocketbear

more options

if I delete my account from firefox does it remove everything ?

more options

crocketbear said

if I delete my account from firefox does it remove everything ?

If you are talking about sync, closing the account will only remove sync from the servers. The data on your computers will not be affected.